cancel
Showing results for 
Search instead for 
Did you mean: 

Infinite loading for blades and sorcery.

Robabobbobinson
Level 2

Hello, I somewhat recently installed Blades and Sorcery Nomad for the Oculus Quest 2.

If I attempt to play the game I am met with seemingly infinite loading screen.

I have seen many other people speak of the same issue.

I have tried every solution within reason to rectify the situation, the only option I haven't exhausted is a complete factory reset of the the device, which is from what I understand to be the only way of fixing the problem.

Apparently the issue is caused by the game being purchased on an account that isn't the Device Owner profile.

I ask that there be an update to the Oculus Quest 2 to allow the game/games to function when being accessed through a profile on the device which is not the owner profile. 

 

1 REPLY 1

OculusSupport
Community Manager
Community Manager

Hey Robabobbobinson! You're on the right track. To resolve the issue you're having with being stuck on the loading screen when trying to play Blades and Sorcery, try these two steps: 

 

1.) Enable Cloud Back Up. Here's how: https://ocul.us/33EWjLc

2.) Then complete a factory reset. Here's how: https://ocul.us/3rFNgS9

 

If you need more help once you've tried these steps, please submit a support ticket to our Oculus Support Team. We are always happy to help.