cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Rift with Euro Truck Simulator 2

cellis34
Level 2
This worked just by simply downloading the May 4th release of Vireio driver and dropping the d3d9.dll and libfreespace.dll into the bin folder for Euro Truck 2. First time I started the game it didn't work (was seeing double images not lined up), but then exited and entered again and from then on has worked.

Didn't even create a profile code or anything. Bear in mind, I am no developer, but just an enthusiast of the rift.

It is rough and the native release will be much better, but for the meantime.....driving the truck like this is amazingly fun πŸ˜„
603 REPLIES 603

bigmike20vt
Level 14
Hi. Not 100% certain but I don't think ets2 demo supports rift you need full game.

It is only cheap tho and well worth it IMO
Fiat Coupe, gone. 350Z gone. Dirty nappies, no sleep & practical transport incoming. Thank goodness for VR πŸ™‚

charlyefun
Level 2
"bigmike20vt" wrote:
Hi. Not 100% certain but I don't think ets2 demo supports rift you need full game.

It is only cheap tho and well worth it IMO


I got the full game and set oculus in the beta tab but still nothing happens..

How do I have to set DK2 ? Primary or Secondary Monitor ? Does Oculus service must be up&running or do I have to kill it ?

can you kindly support me ? tks

t3mr0i
Level 2
You have to rightclick and tehn set the game launch options with the line "-oculus" you could also add "-freq 75 -refresh 75 -refreshrate 75"

FabianAldersey
Level 3
"charlyefun" wrote:


I got the full game and set oculus in the beta tab but still nothing happens..

How do I have to set DK2 ? Primary or Secondary Monitor ? Does Oculus service must be up&running or do I have to kill it ?

can you kindly support me ? tks


Mine worked with the rift set to primary (in extended mode). Then I did a couple of things - put -oculus in the launch options (though I don't know if this is necessary - it seems odd that this is needed on top of running the game in "oculus beta"). I didn't do anything with Oculus service, in terms of killing it. I pressed play, and left it on the "launch game/ direct x blah blah" checkboxes window, WITH DIRECTX SELECTED (not the default "play game" or whatever it is), turned the rift on (for most things I have "show desktop only on screen 2" enabled - my rift is on screen 2 - I do this because my monitor is only at 60Hz), then using one eye in the rift, hit the button to start the game. That worked for me.

charlyefun
Level 2
OK ! Finally I had success ! I was missing in the command line "-oculus".

question: Is it normal that generally speaking the game in oculus are all pretty blurred ?

I also tried to change some graphic configuration but same result.. It's quite frustrating to play..

I have an Nvidia GTX690, nothing changed from Nvidia panel.

Frosty
Level 2
So there's no known method currently for getting the tracking working in this game for DK2, even if everything else renders and looks correct? Me and a few other people have got the same issue, either it not working or working OK then stopping...

Still no suggestions?

FabianAldersey
Level 3
For blurriness, all I can suggest is to set up the ipd in the oculus configuration tool and clean the lenses often. Hopefully the actual screen hasn't somehow managed to get something on it. It depends on your definition of "blurred" - most games/demos I've tried haven't seemed blurred to me, including ETS2.

Regarding loss of tracking, mine's always been fine in ETS2. The camera sometimes shuts off when it hasn't been on for a while, and I need to reboot my PC. Though iI haven't had to do that for a while either. Is it just in ETS2 that the camera stops working? If you close ETS2 and bring up the oculus desk scene, does the tracking switch back on?

charlyefun
Level 2
"FabianAldersey" wrote:
For blurriness, all I can suggest is to set up the ipd in the oculus configuration tool and clean the lenses often. Hopefully the actual screen hasn't somehow managed to get something on it. It depends on your definition of "blurred" - most games/demos I've tried haven't seemed blurred to me, including ETS2.


in my case all games, including of course ETS2, are pretty blurred, not well defined and for this reason very tiring to play.

I would like to know if this is only an issue of mine or maybe some configuration in Nvidia panel (it could be?) non correctly set..

what's the ipd in the oculus configuration ?

thanks for sharing info and support !

museumsteve
Level 4
"charlyefun" wrote:

what's the ipd in the oculus configuration ?


You need to set your IPD in Oculus Configuration when you first get your DK2.
It measures the distance between your eye pupils. This determines how the 3D effect is set in the games/apps. If it is not set or is set wrong it will effect how you see things in the DK2. The first problem you can get is bad eye strain.

When you run games/apps, it reads the IPD from Oculus Config so it is right.

charlyefun
Level 2
"museumsteve" wrote:
"charlyefun" wrote:

what's the ipd in the oculus configuration ?


You need to set your IPD in Oculus Configuration when you first get your DK2.
It measures the distance between your eye pupils. This determines how the 3D effect is set in the games/apps. If it is not set or is set wrong it will effect how you see things in the DK2. The first problem you can get is bad eye strain.

When you run games/apps, it reads the IPD from Oculus Config so it is right.


sorry to bother you but where i can find this option?