cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Desktop says "not on same network"

LR_Daring
Level 3

So...I want to use VD for wirelessly streaming, but I'm suffering from an issue:

My PC connects to wired router(which connects to wired work LAN).

I also need to run an APP to log in with my work account so I can access the Internet.

And my Quest connects to router's wifi but couldn't log in(Quest doesn't support running the APP).

 

Most of the time, VD says "not on same network".

But sometimes, it can connect to my PC.

(Usually at 1st hour after multiple trials of connecting and restarting)

 

Is there anyone knowing how to solve this problem?

Appreciate.

1 ACCEPTED SOLUTION

Accepted Solutions

LR_Daring
Level 3

So...I found the solution myself.

I need to set the gateway and netmask into the same as what's on pc, and make ip address closed to what's on pc(for example: pc is 10.8.11.3, then vr should be something like 10.8.11.2). Restart VD for 2~3 times and it will connect successfully.

View solution in original post

4 REPLIES 4

PITTCANNA
Level 12

you can't run it like that.

 

You need it to be on the same router as the pc, not on a router connected to a router to the pc.

 

So just simply connect it to the router that pc is on.

I did. Both of them connect to the same router.

Well...perhaps I didn't explain clearly in my poor English.

 

But....

I just tried something else, and I found that the reason why they are not on the same network might be that they have different default gateway.

My router is xxx.xxx.200.x, but sometimes the APP sets my pc's to xxx.xxx.204.xx or something else.

I can't control it:

If I change network adapter options manually, my app account will log out immediately(so I won't be able to access the Internet).

But I found that I can refresh my gateway by logging in/out until it turns into 200 so my Quest can connect.

(which means that they are now on real LAN)

I'll try it more times to find out if it's a solution.

 

It's a bad network environment issue in work place, I'm just holding a little hope that someone can help.

Anyway, thanks for you answer. 

I think you are best to join the Virtual Desktop discord channel.  You'll get lots of help regarding setups and useful tips there.  The developer often directly helps as well which is very nice.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Quest 2 w/Air Link, Vive Pro.

LR_Daring
Level 3

So...I found the solution myself.

I need to set the gateway and netmask into the same as what's on pc, and make ip address closed to what's on pc(for example: pc is 10.8.11.3, then vr should be something like 10.8.11.2). Restart VD for 2~3 times and it will connect successfully.

View solution in original post