Showing results for 
Search instead for 
Did you mean: 

Developer Mode Issues Update

Oculus Community Manager
Oculus Community Manager

Hello everyone,


Thank you all for your reports and your patience on this issue! In regards to developers being unable to enable Developer Mode in the Oculus app, a new update has been pushed to fix the issue. Please update your Oculus app to the latest version (as of the date of this post) and try enabling Developer Mode once more.


Update 11/8The fix pushed to the latest App Update does not seem to have fixed the issue for all developers. At this time we are re-opening the issue and will update this post as well as this forum thread with any relevant details.


In the meantime, many of our awesome developers have shared that verifying using a Credit Card allowed the Developer Mode option to appear. 


Update 11/15: We have received reports that this issue has been fixed for most developers experiencing this issue. Please log out and log back into your Oculus app and try enabling Developer Mode once more. If you still experience the same issue, please reach out to our team at (click "Contact Us") and we'll dive deeper.


Level 3

Tried it today, it's still not fixed

Level 2

I can't update my oculus app, so I still can't turn on developers mode.

Level 3

is there a proposed date for the solution? I still have the same problem and I already did everything, I even added a payment method, the cell phone, update everything to the latest and the developer mode still does not appear.

Level 3

I don't know if this will help, but I have the version of the Oculus app, dated November 2nd, and still have the issue. This matches that latest version listed on the Google Play Store website so the new version hasn't changed anything related to the bug.


Level 2

Any News about developer mode in android app ?

Developer Hub only works if your computer has Bluetooth, which mine does not. It doesn't enable developer mode over USB, only via Bluetooth on the Quest 2.

How exactly do I connect my device to Developer Hub with bluetooth? All I get to see when I click on "Set Up New Device" is them telling me to turn on Developer mode, but the whole reason why I've installed this program is to be able to turn it on. I've been trying so much nonsense, but nothing has worked for me. Please help me someone, I'm begging you.

Unfortunately, it's happening all over to everyone, basically. It's a bug and it's their fault, and there's nothing anyone can do about it until they fix it. And all they keep saying is "update your app" and everyone has been updating their app and it's still broken. All we can do is wait and keep checking up on this forum until someone posts that it's finally working.

I would expect you need to go into windows settings and pair the quest 2 with your PC first. Then start Developer Hub and it will either show up automatically, or you may need to "Device Manager" on the left pane then click "Setup new Device".


In the past I already had developer mode turned on in my Quest 2 and it just showed up in Developer Hub when plugged in via USB, but thanks to some weird bugs I did a full factory reset which lost me ADB access, hence my current issues.