cancel
Showing results for 
Search instead for 
Did you mean: 

How to Download Asset Files not Marked as Required

brazzoni
Level 4

When uploading a build to the developer hub, you can mark assets as required. If you don't mark assets as required, they will not be downloaded.

 

Are non required asset files never downloaded? Or is there a way to download them. In one of my builds, 3 asset files keep getting marked as non required, and I need to figure out how to get them to download in an update or something.

 

Marking them as required, in the developer hub, does not seem to make them download on subsequent updates.

1 ACCEPTED SOLUTION

Accepted Solutions

BigFluffyCookie
Level 2

Yes you can download them later, however is that the goal? Or is the problem that these 3 asset files aren't being marked as required? 

 

As soon as you make it required in the developer hub it should download the asset files when you reinstall your app. If you want them to always be required instead of having to mark them afterwards in the hub you should create an --asset-files-config.

 

The other option is to download the missing files when the application starts with this -> https://developer.oculus.com/reference/platform/v35/o_v_r_asset_details_8h

(if thats what you mean I can give you a bit of a better explanation on how to implement it) 

View solution in original post

2 REPLIES 2

BigFluffyCookie
Level 2

Yes you can download them later, however is that the goal? Or is the problem that these 3 asset files aren't being marked as required? 

 

As soon as you make it required in the developer hub it should download the asset files when you reinstall your app. If you want them to always be required instead of having to mark them afterwards in the hub you should create an --asset-files-config.

 

The other option is to download the missing files when the application starts with this -> https://developer.oculus.com/reference/platform/v35/o_v_r_asset_details_8h

(if thats what you mean I can give you a bit of a better explanation on how to implement it) 

I had to publish another build with no changes (other than fixing my expansions-config.json), so the headset recognizes it needs to update.