cancel
Showing results for 
Search instead for 
Did you mean: 

OVR Platform Util Weird Error

Iwo_2401
Level 2

Hi guys,

 

When i run "[...]\Assets\Oculus\VR\Editor\Tools>ovr-platform-util help", i get the following error:

 

node:fs:585
handleErrorFromBinding(ctx);
^

Error: UNKNOWN: unknown error, open 'D:\full-fbsource\arvr\js\node_modules\yargs\locales\en.json'
←[90m at Object.openSync (node:fs:585:3)←[39m
at Object.openSync (pkg/prelude/bootstrap.js:739:32)
←[90m at Object.readFileSync (node:fs:453:35)←[39m
at Object.readFileSync (pkg/prelude/bootstrap.js:1025:36)
at o._readLocaleFile (C:\snapshot\D_Zfull-fbsource\edenfs\redirections\arvr\js\temp\build-ovr-platform-util\lib\ovr_platform_util.js)
at o.__ (C:\snapshot\D_Zfull-fbsource\edenfs\redirections\arvr\js\temp\build-ovr-platform-util\lib\ovr_platform_util.js)
at C:\snapshot\D_Zfull-fbsource\edenfs\redirections\arvr\js\temp\build-ovr-platform-util\lib\ovr_platform_util.js
at Object.<anonymous> (C:\snapshot\D_Zfull-fbsource\edenfs\redirections\arvr\js\temp\build-ovr-platform-util\lib\ovr_platform_util.js)
at C:\snapshot\D_Zfull-fbsource\edenfs\redirections\arvr\js\temp\build-ovr-platform-util\lib\ovr_platform_util.js
at a (C:\snapshot\D_Zfull-fbsource\edenfs\redirections\arvr\js\temp\build-ovr-platform-util\lib\ovr_platform_util.js) {
errno: ←[33m-4094←[39m,
syscall: ←[32m'open'←[39m,
code: ←[32m'UNKNOWN'←[39m,
path: ←[32m'D:\\full-fbsource\\arvr\\js\\node_modules\\yargs\\locales\\en.json'←[39m
}

 

I google it but i seem to be the first one with this error ;(

8 REPLIES 8

Iwo_2401
Level 2

The problem was that my CD Drive had the letter 😧

After changing 😧 to Z: via DiskManagement Tool, it worked again 🙂

For me, this had to do with the fact that my D drive was still locked with BitLocker. Error: UNKNOWN: unknown error, open shows which file/drive it cannot access

Ditronian
Level 2

Nothing I try seems to fix this.  I've never even had a D Drive, or any kind of CD Drive on this PC.

  •  

I'm getting this same error now, and it's not due to a wrong drive. It doesn't even matter if I include the arguments, I still get this exact same error. And I can't get Oculus Developer Hub to upload a build, either, as it just gives the vague "Build Upload Error - an error has occurred" that's all the rage these days.

oooh_julian
Level 2

Same error and also can't upload via Oculus Developer Hub due to the error "Build Upload Error - an error has occurred"

One point of data: my coworker has 2.7.1 and it works fine for him. I'm pretty sure I HAD 2.7.1 when it first broke for me today, then I updated to 2.7.2 and it still didn't work. So it doesn't seem to be a specific version so much as something machine-specific.

Ditronian
Level 2

Was able to fix mine, apparently having my headset's Link cable plugged in was causing the issue...creating a sort of hidden D Drive even though it was powered off...