cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Go ABD drivers(1.0) Issue

AQfumes
Level 5
Has anyone had problems with Oculus Go adb drivers causing the the directory drive for the Go to disappear, after installing the adb drivers?

I installed the 1.0 version of the adb drivers and now the drive for the Go vanishes from my computer, so I can no longer access the Go's directory folders. I tried uninstall/delete the Oculus adb drivers from the Device Manager and this did not fix the issue. I had to do a complete system restore on my computer to resolve the problem causing my Go drive to disappear. 

I attempted to connect the Go with the Android adb but it did not find the Go under listed devices. I'm wondering if this has to do with the issue I'm having with the Oculus adb driver.

Has anyone had success connecting the Go with the Android adb? 
18 REPLIES 18

MintPot
Level 3

AQfumes said:

I wasn't able to get the Oculus ADB driver (ver1.0) to work for me, so I resorted to using the Samsung USB drivers instead located here: https://developer.samsung.com/galaxy/others/android-usb-driver-for-windows

There must have been a bug in 1.0, cause it looks like they updated the Oculus adb driver to a 2.0 ver. today:  https://developer.oculus.com/downloads/package/oculus-go-adb-drivers/

I haven't tried it yet. 




Have you tried it?
I try it but fail...
I can access device storage but 'adb devices' is empty..

PeepinTheGame
Level 3

MintPot said:


AQfumes said:

I wasn't able to get the Oculus ADB driver (ver1.0) to work for me, so I resorted to using the Samsung USB drivers instead located here: https://developer.samsung.com/galaxy/others/android-usb-driver-for-windows

There must have been a bug in 1.0, cause it looks like they updated the Oculus adb driver to a 2.0 ver. today:  https://developer.oculus.com/downloads/package/oculus-go-adb-drivers/

I haven't tried it yet. 




Have you tried it?
I try it but fail...
I can access device storage but 'adb devices' is empty..


I'm in the same boat as you. Hopefully, this will be fixed soon. Keep us posted. 

MintPot
Level 3
wow! success!

I used two methods.

1. factory reset
https://support.oculus.com/166300084150879/

2. Enable developer mode 'on mobile'
and connect oculus go to PC

Antimon
Level 3
I was having Trouble as well, but finally managed to install my app on the GO. This is what helped me.

1. Using the Samsung Driver instead of the Oculus adb Driver.
https://developer.samsung.com/galaxy/others/android-usb-driver-for-windows

2. Really switching developer mode on the Smartphone off.
That let the device appear on the Windows Explorer.

3. I also followed this tutorial for settings along the way:
https://medium.com/@jasteinerman/how-to-build-an-app-for-the-oculus-go-from-start-to-finish-with-uni...

This helped me solving issues like the correct path for the Android and Java sdk and by doing that solving also that error with the wrong target platform.

4. After succeding with the apk built, I still had issues with adb, as Android Studio stated the device is not authorized. Then I realized, when using the adb via Android Studio, I constantly had to Switch between the Android window on my PC and the Oculus GO, as the GO several times asked for permission during the process. At that Point I had to Switch the developer mode on the phone ON again btw.

As said though, in the end it worked and I found my built in the Unknown Sources Folder of my GO library.


immersionVR-adm
Level 2
For those having problems with Oculus Go and adb, after many hours attempting to get the Oculus Go to show up as a valid device when listing devices thru adb and having tried every combination of solutions provided in this and other forums (including updating drivers, rebooting, factory resetting....) I have just updated my adb version which was version 1.0.32 to version 1.0.39 and the headset finally appeared! 🙂


casyi
Level 3


For those having problems with Oculus Go and adb, after many hours attempting to get the Oculus Go to show up as a valid device when listing devices thru adb and having tried every combination of solutions provided in this and other forums (including updating drivers, rebooting, factory resetting....) I have just updated my adb version which was version 1.0.32 to version 1.0.39 and the headset finally appeared! 🙂




Tried everything in this thread and then read this haha. This worked for me. Thank you! 

Ga7ahad
Level 3

casyi said:



For those having problems with Oculus Go and adb, after many hours attempting to get the Oculus Go to show up as a valid device when listing devices thru adb and having tried every combination of solutions provided in this and other forums (including updating drivers, rebooting, factory resetting....) I have just updated my adb version which was version 1.0.32 to version 1.0.39 and the headset finally appeared! 🙂




Tried everything in this thread and then read this haha. This worked for me. Thank you! 


did you update the Samsung adb driver for this fix? Thx! 

Lightowl
Level 3
For me it was just the sequence in which i did things. Originally I had the Go attached to the PC and then enabled developer mode on my smartphone.  Which didn't work, I couldn't build to the Go.  I then disconnected the Go, rebooted it and connected it to the PC and I got a permission message allowing the pc to connect to the Go.  After that I was able to build to the Go. Nothing fancy.

Revan0
Level 2
I know it's old but i keep forgetting this, i just did a factory reset and came upon this same issue, again. After trying everything here's how i did it:

- I installed the adb drivers from oculus
- I made sure to connect my headset to the computer once before enabling dev mode (then disconnected it)
- I removed the unlock pattern on my device 
- I enabled dev mode
- I launched my adb software
- I connected the device to my computer
- I looked into the device and the prompt appeared, i ticked the box to always allow, and clicked to allow the device

Really don't put an unlock pattern before that otherwise it will not work, the prompt in the headset to allow the device will not appear, it's the mistake i kept making, once i removed the pattern everything worked out great.

Also hi to future me that will definitely forget about this and make the same mistake again for 5th time at least now!