cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to find libAudioPluginOculusSpatializer Error ..What is the solution?

motiontech12
Level 2
Hello. Oculus Quest Bulid Testing.
Unity Version 2019.3.9fLTS
Oculus SDK newest version
Bulid il2cpp ..

Build in the above environment, but this problem occurs in the Oculus Sample scene.
What is the solution?


02-02 15:00:23.591 11081 11095 I Unity   : SystemInfo CPU = ARM64 FP ASIMD AES, Cores = 3, Memory = 3805mb
02-02 15:00:23.591 11081 11095 I Unity   : SystemInfo ARM big.LITTLE configuration: 3 big (mask: 0xe0), 0 little (mask: 0x0)
02-02 15:00:23.591 11081 11095 I Unity   : XR UsableCoreMask: 0xe0
02-02 15:00:23.592 11081 11095 I Unity   : ApplicationInfo com.DefaultCompany.Oculus_Haptics_Test version 0.1 build 13f3823a-2225-4b5f-9918-138ae83092ef
02-02 15:00:23.592 11081 11095 I Unity   : Built from '2019.4/staging' branch, Version '2019.4.9f1 (50fe8a171dd9)', Build type 'Release', Scripting Backend 'il2cpp', CPU 'arm64-v8a', Stripping 'Enabled'
02-02 15:00:23.737 11081 11095 E Unity   : Unable to find libAudioPluginOculusSpatializer
02-02 15:00:23.742 11081 11095 D Unity   : loading library OVRPlugin
1 REPLY 1

motiontech12
Level 2
Self answer..
Problems with Oculus Android Package installed from PackageManager in Unity 2019.4.
The solution is to go to "Library\PackageCache\com.unity.xr.oculus.android@2.38.6\Plugins\Android" and delete the "libAudioPluginOculusSpatializer".
Already included in the Oculus Integration SDK.