cancel
Showing results for 
Search instead for 
Did you mean: 

Apps ang games

ztargames
Level 2

Browsing Apps and games from Sweden does not work on any browser. Any one who has this problem?

13 REPLIES 13

prufrax
Level 4

Not just Sweden - can't browse their website for apps and games from here in the UK either - tried firefox and chrome and neither work. Looks like the javascript on the page explodes cause something on their servers is serving up an empty string instead of a parsable JSON blob....

Hey, prufrax! We know this can be quite frustrating, and we'd like to get more information on this issue. Are you receiving an error message when trying to access our site? If so, can you kindly provide us with screenshots? Thanks! We look forward to helping you get to the bottom of this. 

prufrax
Level 4

Uncaught (in promise) SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

file is: www.oculus.com / x2asset / 9ce0cb0bb1d3082720ddf29d8577764d3e3984d3 . js

 

(spaces inserted as forum does not seem to like posting the stack traceback - maybe the earlier posting with the full traceback is lurking in quarantine or awaiting moderation?)

Hey there! Thank you so much for providing us with this information. It helps us figure out what steps to provide you with. Can you please clear the cache on your computer and then restart it in this specific order? Thanks! We hope this was of help. 

radkovski
Level 2

This is the error screenshot. Apps and games not working on Chrome and Safari. Also tried in Incognito Mode and same issue. Woking on Firefox. Also tested on mobile, same thing. Chrome, Safari not working, Firefox is working

 

Screenshot 2022-05-31 at 09.31.23.png

yezFV
Level 3

Yup, https://www.oculus.com/experiences/quest/ etc is stuck on the loading wheel for us, in all browsers. Windows Chrome, Edge, Firefox, iOS Chrome, iOS Safari.

Chrome shows the same error as @radkovski.

foxytocin
Level 2

I can confirm that. The store has not been available for days. I'm getting similar errors in the browser console.

I dug into this a little bit more earlier - on my work machine that has never visited oculus.com before and so no stale cache issues.

The throw is when the contents of an undefined variable is attempted to be deocded as JSON.

The variable is undefined because it is the value from a dictionary - but the variable that should contain the dictionary (rawDictionary) is not a dictionary but instead a string containing a the path to a json file. So something is passing in wrongly-encoded data somewhere.

The function where this happens is trying to load locale-specific translation data from the webpack. This may be why it is not failing for you in en_US, but is failing for us in en_GB and other locales - i.e bad or misformatted locale data for non-default language locales in the webpack.

Will dig out the exact file name in the variable later when I'm not juggling six things!

prufrax
Level 4

Screenshot from 2022-05-31 17-17-15.png

So here we have it - prettyprinted the packed js, and we can see that rawDictionary = "/x2asset/edfcdee7b0cbe883cb40a78c3caecff6.json" rather than being a dictionary.

Result is the loop going through this 'dictionary' is setting translatedPayload = '/' which is not valid json.

Check your packaging of non-default (i.e. not en_US) locale data. Something is wrong in there.