cancel
Showing results for 
Search instead for 
Did you mean: 

Can't find "Phone Notification" option to enable Android notifications in V34 update

JeffNik
Level 7

I have upgraded to V34 and wanted to try out the Android phone notifications on my Quest. You're supposed to initiate the feature by going to the mobile app, under "devices" and enable the "Phone Notifications" option there. My mobile app does not have "phone notifications" under "devices"... just:

wi-fi

controllers

developer mode

[etc]

 

... am I looking in the right place? I believe I'm on the most recent app version - there no update option in the play store. Any ideas? Maybe the feature isnt available yet for my Galaxy S21?

265 REPLIES 265

ericle7
Level 4

Speaking for myself, I've tried it both ways -- leaving the Oculus app open and not.

If I fiddle enough, I can get the notification feature configured, but I don't receive notifications of incoming texts.  I have a Google Pixel 6 Pro: a new flagship phone from the company that maintains Android, running the OS version.  It's hard for me to understand how this feature can be broken for so many people.  These aren't exactly unusual "corner cases" -- I'm hearing people with common phones where the feature simply doesn't work.

I wish one of the developers would take a minute to explain how the feature is implemented.  There are developers on this thread (like myself) who could probably help troubleshoot.

Yes, because I saw someone mention that. But even so, that'd be weird to force us to do that every time.

I also just realized my normal notifications from the built-in messenger app stopped appearing. I don't know what's going on. I haven't tried resetting experimental features yet, though.

Hi @ericle7 , yep that's exactly what I was trying to describe. It's still like that for me, no matter what I do (have uninstalled app, deleted all app cache/storage, etc).

 

It eventually gets to that screen and when I move the slider it immediately moves back.

THERE IS NO PHONE NOTIFICATION OPTION THATS THE PROBLEM!

I finally got it working. What I did was deactivated the feature in both the phone and the headset. Then activated it again in the phone and did the pairing process. (Already had the phone and headset paired over bluetooth using the experimental bt, but I don´t think that is needed).

Roymus
Level 3

Still can't see text messages, but I am now seeing other types of messages showing up when I click on the Notifications badge (bell icon).  Question for those of you who have it working:  do text messages show up in your headset in the middle of a game?  Or do you have to go back to the home env and click the notifications badge?

 

I've been trying to test this by sending myself text messages, could that have something to do with why it's not working?

Yes text messages show up in the middle of the game.  I do not have to go back to notifications.

NorbertNoBacon
Level 3

Getting pretty fed up with Android users taking a back seat to iOS feature wise. This is especially ironic when the Quest 2 OS is based on Android! Maybe take some time to test your updates before you roll them out so they work correctly and actually have some parity between platforms too. It's not an unreasonable request.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey NorbertNoBacon, thanks for reaching out to us about the Android Notifications bug. The feature is definitely a great one, being able to see all of the notifications you'd potentially miss while in VR. According to the community post, this issue should have been resolved but if not, there's some helpful things below you can try!
 

  1. Uninstall the oculus app.

  2. Install the oculus app again.

  3. Log in with your facebook account to the oculus app.

  4. Don't go to headset settings yet, and close the app and go to app info.

  5. Force stop the app.

  6. Enable all permissions for the app. Including the one to install unknown apps.

  7. Start the app and you should now see the phone notifications option under headset settings.

    If this doesn't solve the issue, you can try clearing your app data, and app cache, then repeating the above steps. You may also need to go to your phone settings and enable notification access for the Oculus app.

Please let us know if this doesn't resolve your issue! You might also consider reporting a bug or submitting a support ticket. Cheers!

Here's the thing some have done this over and over. Some have the settings all set and ready to go. Still no notifications coming through. Install uninstall force stop everything has been tried.