cancel
Showing results for 
Search instead for 
Did you mean: 

Enable 90Hz On Oculus Quest 2 Games And Virtual Desktop!

Zenbane
Level 16
I am looking forward to trying this out this weekend. Has anyone attempted this yet?!

A new unofficial workaround allows users to enable 90Hz mode for games and apps on Oculus Quest 2, despite the feature being disabled at launch.


What You Need

You’ll need an Oculus Quest 2 — to our best knowledge, this method will not work on the original Quest.
Make sure you also have a USB cord to connect the Quest to your computer — any USB A to C cord (or C to C, if your computer supports it) should work.


Running Games At 90Hz On Quest 2

If you’ve never sideloaded anything onto your Quest 2 before, there are a few first-time setup steps that you need to do before enabling 90Hz. Check out our article on sideloading on Quest and follow all the instructions in the ‘Initial Setup’ section — enable developer mode, installing SideQuest and enabling debugging between your computer and Quest 2.

Once that’s all sorted, here’s how you enable 90Hz for apps:
1. Open SideQuest
2. Connect your Quest to your PC via the USB cord and confirm the headset is connected to SideQuest
3. Press the ‘Device Settings & Tools’ button, represented by a spanner, in the top right of the SideQuest toolbar
4. Click the 90Hz button under ‘Refresh Rate’
5. Press the power button on the Quest once to turn the screen off, then once more to turn it back on.


Games should now be running at a higher 90Hz refresh rate — we tested and confirmed that it works at a stable 90fps for both Echo VR and Beat Saber

However, generally speaking, this may be dependent on whether an app is already ’90Hz-Ready’ or not. Upping the refresh rate to 90Hz did not seem to have a positive impact on Solaris: Offworld Combat, for example, and if anything may have caused more variability in its performance

If you turn the headset off and on again, it will revert to 72Hz and you will have to go back to SideQuest and press the 90Hz button again

You can disable 90Hz by repeating the process above but pressing the Default of 72Hz buttons instead.


Manual ADB Command Method

Before SideQuest implemented the 90Hz setting, which simplified the process, this was the original method which uses ADB commands:

1. Open SideQuest
2. Connect your Quest to your PC via the USB cord and confirm the headset is connected to SideQuest
3. Press the ‘Run ADB Commands’ button in the top right of the SideQuest toolbar, then select the ‘Custom Command’ option
4. Paste and run the following command:
adb shell setprop debug.oculus.refreshRate 90

5. Press the power button on the Quest once to turn the screen off, then once more to turn it back on.

Alternatively, you can disable 90Hz and go back to the standard 72Hz by running this command:

adb shell setprop debug.oculus.refreshRate 72


Full detailed instructions and images here:
https://uploadvr.com/90hz-games-oculus-quest-2-how-to-virtual-desktop/
6 REPLIES 6

benplace
Level 8
So the 90hz option in the Quest 2 under settings/experimental doesn't work??

Zenbane
Level 16

benplace said:

So the 90hz option in the Quest 2 under settings/experimental doesn't work??



It only works in the main home environment and when using the Oculus Browser.

But it doesn't seem to take effect when launching the VR Titles themselves. Hence the above workaround.

TomCgcmfc
Level 16

benplace said:

So the 90hz option in the Quest 2 under settings/experimental doesn't work??


The experimental option for 90Hz only currently works with Quest 2 menus (and browser?), not games.

On the Virtual Desktop discord channel, the founder (Guy), has said that there is not much advantage, if any, to do the overall 90Hz hack at this point in time since most games do not currently support it anyway.  Also, you need to redo this hack every time you power off/on your Quest 2.

Probably best to wait for Oculus to officially (maybe still an experimental beta option) offer a 90Hz refresh option.  Apparently they just need to do a few mods to the Quest 2 Guardian system before doing this.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Nunyabinez
Level 8
FYI, definitely does not work for Link. The app just crashes.

i7 8700, 16GB, RTX 2080 TI, Rift CV1 | i5 4690K, 16GB, GTX 1660 TI, Rift CV1 | Quest | Quest 2

Sharpfish
Level 7
Yeah I'm using this for DEV WORK (not for running or trying to run other games so no need for sidequest here just straight from UE4 and a CMD window for ADB control), it's great - at least - to see overhead and how much 'spare' power (without drops) you have over and above the standard 72hz. nice to dev with a higher frame rate too. I plan to target 90hz for some future date when it's officially supported as 90hz is way better (for presence for one)

I have a .bat file that I run to connect wirelessly to Q2 to send dev builds to it (click/run once at start of dev session), and it sets it to 90hz at the end of that with the adb commands. Quest 2 is really cool. Am suprised by how much you can ram into that tiny system before it starts losing frames!

EX DK2/VIVE/PSVR | Currently RIFT CV1 & Quest 2 | Future Reverb G2 | VR developer RTX 3080 FE / 8700k / Windows 10 Pro

gamecay
Level 2
Could you share the bat file as having to use sideloader everytime is a real pain? That'd be awesome.