cancel
Showing results for 
Search instead for 
Did you mean: 

How to prevent Home from starting when playing Steam games

ApollyonVR
Level 8
Hi all!
Just thought i'd share this nifty trick found by user @droseofc while we where troubleshooting some stuff regarding Oculus Tray Tool. If you set Oculus Home to Run as Administrator, it will not automatically launch in the background when starting Steam VR games. This might save some valuable resources as well as make Steam games launch faster. This will also, however, cause Home to not start automatically when you put the Rift on your head. So there's two sides to this so to say. To set Home to start as Administrator, you right-click the Oculus shortcut -> Properties ->  Compatibility and down at the bottom you check the box "Run this program as an administrator". Done!

You might need to start Oculus Home manually one time and dismiss the Health & Safety warning so you get into the lobby. After this you can close Home and start Steam VR games as usual and it should work fine with no Home starting up in the background.
So this might need to be done every time after you've restarted your PC. As i mentioned this was discovered by @droseofc, i just tested and verified it. Hope someone finds it useful, couldn't find any existing posts about it. 😃

Cheers!
24 REPLIES 24

droseofc
Level 4

      I have, from what I can tell and confidently say, definitely seen a big difference, especially in the speed of launching a SteamVR game vs launching a SteamVR game with Oculus running in the background. And its not a problem I usually have, SSDs, i7, NV 1080, 16GB ram, I mean I don't have a problem launching stuff so when I say it makes a difference I would imagine for a pc with the same or less of my pc there would be a noticable difference too.

      And as for performance, I could not tell any difference, besides negatively, of running with Oculus vs without in terms of graphical and experience, except the bad one of having multiple virtual reality programs running simultaneously.

Oculus tray tool has an option to set ASW mode, but really it boils down to....

ATW/ASW on Rift via SteamVR



I've seen some confusion online regarding this and wanted to set the record straight.

When running the Rift through SteamVR, the Oculus runtime is still responsible for presenting images to the device's screen. The SteamVR compositor adds chaperone, the dashboard, etc. but then hands off the textures to the Oculus compositor for it to perform its own distortion correction, chromatic aberration correction, etc. This also allows their framerate mitigation techniques (i.e. ATW and/or ASW to kick in), bypassing our own implementations of similar techniques.


droseofc
Level 4
I imagine he is talking about the OVRServer_x64.exe and/or the OVRService that does run, constantly I believe.

CaTaPulT88
Level 3
The easy way to make it so Oculus Home does NOT start when you want to run SteamVR is to right click the Oculus shortcut on your desktop, choose "properties" then choose the "compatibility" tab, then click the "run this program as an administrator". To run Oculus Home once you have done this, you have to double click the desktop shortcut. 🙂

droseofc
Level 4


The easy way to make it so Oculus Home does NOT start when you want to run SteamVR is to right click the Oculus shortcut on your desktop, choose "properties" then choose the "compatibility" tab, then click the "run this program as an administrator". To run Oculus Home once you have done this, you have to double click the desktop shortcut. 🙂


Right, same steps as its been since post 1. 

WreckLuse68
Level 7

crossmr said:

I just did this, clicked on the oculus short cut in my start menu, set it to administrator, then fired up SteamVR but Oculus Home opened anyway.

I also tried doing this directly on the oculus client file here: C:\Program Files\Oculus\Support\oculus-client and it made no difference, oculus home still launches with SteamVR.




You may need to set your windows security settings...I have my Home set to 'run as admin' and I get the yes/no option when I run Home direct from a shortcut...this stops it from loading with Steam.
When Einstein was asked how it felt to be the smartest man on Earth, he replied, “I wouldn’t know. Ask Nikola Tesla”.