cancel
Showing results forย 
Search instead forย 
Did you mean:ย 

How to prevent Home from starting when playing Steam games

ApollyonVR
Level 8
Hi all!
Just thought i'd share this nifty trick found by user @droseofc while we where troubleshooting some stuff regarding Oculus Tray Tool. If you set Oculus Home to Run as Administrator, it will not automatically launch in the background when starting Steam VR games. This might save some valuable resources as well as make Steam games launch faster. This will also, however, cause Home to not start automatically when you put the Rift on your head. So there's two sides to this so to say. To set Home to start as Administrator, you right-click the Oculus shortcut -> Properties ->  Compatibility and down at the bottom you check the box "Run this program as an administrator". Done!

You might need to start Oculus Home manually one time and dismiss the Health & Safety warning so you get into the lobby. After this you can close Home and start Steam VR games as usual and it should work fine with no Home starting up in the background.
So this might need to be done every time after you've restarted your PC. As i mentioned this was discovered by @droseofc, i just tested and verified it. Hope someone finds it useful, couldn't find any existing posts about it. ๐Ÿ˜ƒ

Cheers!
24 REPLIES 24

droseofc
Level 4
     It really does make a huge difference, at least on my pc. Seems SteamVR games start up almost instantly, where before there was a wait while it loaded. I do not have to redo after every reboot, and I do have the health and safety warning disabled as well as unknown sources checked.
     If you press the Oculus menu button while playing a steamvr game the screen will just turn black until you press it again, since the Oculus client is not loaded..  At least I'd assume, with the amount of resources required to run VR, being able to only have one running instead of two is the ideal option. 

dburne
Level 16
This is awesome and works great, many thanks for this tip! I had to install Steam VR begrudgingly
for playing IL-2 Battle of Stalingrad  as it was the only platform supported, now I can launch the game much faster without Oculus Home starting up as well. Have not had a chance to check any performance comparisons but certainly can not hurt!

Thanks very much for sharing!
Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |

dburne
Level 16



You might need to start Oculus Home manually one time and dismiss the Health & Safety warning so you get into the lobby. After this you can close Home and start Steam VR games as usual and it should work fine with no Home starting up in the background.
So this might need to be done every time after you've restarted your PC

Just tested on mine, did not need to set it upon any restart of PC. I had already previously dismissed the Health and Safety Warning though as well.
Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |

Redstone13
Level 2
HI, this solution worked great for me, but not anymore. I had to run the oculus setup again yesterday and now it's back to opening home whenever I open steamvr.  run as administrator is still checked and the headset does not turn on when I put it on so I can't figure out why it's doing this.  I almost never use the oculus store and having it run in the background KILLS my performance as it is an absolute RAM whore.  Can someone help?

droseofc
Level 4


HI, this solution worked great for me, but not anymore. I had to run the oculus setup again yesterday and now it's back to opening home whenever I open steamvr.  run as administrator is still checked and the headset does not turn on when I put it on so I can't figure out why it's doing this.  I almost never use the oculus store and having it run in the background KILLS my performance as it is an absolute RAM whore.  Can someone help?


You may have to re-check the Safety Warning Screen setting, it most likely shows it as being disabled already, but for me, I had to check it (enable it) and then uncheck it (disable) in order for it to go back to how it was before.

droseofc
Level 4
Also, there are two options for running as administrator within the shortcut properties. First one is in Compatiblity Tab, and the second is within the bottom option of that tab that says "Change settings for all users". In that option, there is also a run as admin box. Check that one, I am pretty sure it is more permanent than the first one, because when it is checked it grays out the previous option before it. I check both, first the one on compatibility, and then inside the change for all users next. Apply, and then ok.

sherpa25
Level 4
You guys know how I can put Oculus Home to startup when I boot Win10? Tried including Oculus Client in startup via shell:startup but it doesnt start with Win10.

Also, any way to turn off the Health warning? Already have it turned off in OHome, but every start of OHome, it keeps showing up. Tnx.

droseofc
Level 4

sherpa25 said:

You guys know how I can put Oculus Home to startup when I boot Win10? Tried including Oculus Client in startup via shell:startup but it doesnt start with Win10.

Also, any way to turn off the Health warning? Already have it turned off in OHome, but every start of OHome, it keeps showing up. Tnx.


You might have to re-enable the health warning and then disable again. If you use the Oculus Tray Tool, there is an option to launch oculus home when windows starts. I am not positive, but it may or may not work if you have the "Run as administrator box" box checked for launching steam without oculus. Not sure though. I only would imagine as it prevents it from running normally, then it might prevent it from launching at start as well. Not positive though, nor am I about the Oculus Tray Tool, as I've never tried the launch at start up option, but it is there.

sherpa25
Level 4

droseofc said:


sherpa25 said:

You guys know how I can put Oculus Home to startup when I boot Win10? Tried including Oculus Client in startup via shell:startup but it doesnt start with Win10.

Also, any way to turn off the Health warning? Already have it turned off in OHome, but every start of OHome, it keeps showing up. Tnx.


You might have to re-enable the health warning and then disable again. If you use the Oculus Tray Tool, there is an option to launch oculus home when windows starts. I am not positive, but it may or may not work if you have the "Run as administrator box" box checked for launching steam without oculus. Not sure though. I only would imagine as it prevents it from running normally, then it might prevent it from launching at start as well. Not positive though, nor am I about the Oculus Tray Tool, as I've never tried the launch at start up option, but it is there.


Will try that, re-enabling it and disabling again.

Yeah, enabled in OTT but it doesnt start up. Weird too that OHome minimize button usually actually closes the OHome client, and I have to run it again... but thats more of an OHome issue.