Showing results for 
Search instead for 
Did you mean: 

Oculus Client issues that need to be fixed for the ecosystem to not become infuriating to deal with

Level 5

I'm making this thread to address issues specifically regarding the Oculus Client that need to be fixed.

Now, I know these have a solution in common, but I'll explain why it isn't a good solution in the long run, and merely a band-aid.

So, here's the issue:
When you install something, sometimes, it'll say "attention required"
You'll click to continue, and it'll proceed to tell you the same thing again.

Most of the time, at the same time as this issue occurs, if an Oculus update is happening, it'll download itself in multiple patches, and proceed to never finish the last patch,
staying on the play/pause button showing the pause icon, but not being clickable.

The solution:
Reinstall Oculus Software entirely.

Sure, this might seem simple.
It would be simple.

But this issue shows its ugly head again after a while, so you constantly have to do it.
And the kicker?
Mandatory 5 gigabyte download every time.

Not only that, but even the solution has a bloody issue! It never stops!

Every single time I have attempted to reinstall Oculus,
it has given me errors before finishing installation, telling me to restart my computer, which of course, wouldn't bloody work!
An endless installation error loop, for which we're given a few steps:

First step:
Try again

Second step:
Remove registry entries of Oculus
Try again

Third step:
Remove the entire download cache on C drive.
Try again, and wait for another 5 gigs to download

If you end up at the third step or even the second one, there is a likelyhood that Oculus won't remember what account was on there,
what games it had available on it, and will proceed to uninstall all your Oculus games before loading you into a fresh Oculus Client, 
redownloading all your games again

I need not remind you that is over 40 gigs potentially.
And playing any game in the Rift during that time means those 40 gigs will stop downloading!

And that's only if those steps bloody worked!

This is infuriating!

This is so much further from what this ecosystem is clearly supposed to be that it simply baffles me!
Please fix these issues for good!
For the love of all that is Holy!

Level 4
I agree, some aspects of the client could be more streamlined than it is currently. Doing things like uninstalling and reinstalling the client should require you to delete all of your games, and neither should it have you going all the way into your registry to remove files. These are things the program itself should be able to handle without the user having to worry about it.

Level 5
Also you should be able to fully uninstall a game/app and remove it from your libary. 
I have loads games and apps in my library that I am never going to use again.

Level 5
This is still not fixed.
I've sent as feedback, and hope to see these issues fixed.

A solution to the installation problem would already be to just put the third party drivers in a redist folder for each individual game, and let us deal with it instead of trying and failing to do it automatically.

This has happened to me 9 times so far, and I've had my Rift since November.

Level 5
Well then, I'm seeing that the Oculus Setup itself now attempts to install third party drivers while installing Oculus Client itself

This makes it even more prone to failing to install properly than before!
On top of that, you can't tell it to use half the bandwidth, and it freezes randomly while downloading, needing to be restarted!

Please, Oculus, Please! Why is the OculusClient such a pain in the ass!

Level 5
If you have to reinstall the software backup your games first.
C:\Program Files\Oculus\Software\Software
Move this folder to a different location on your hard drive then after you reinstall put the folder back and you should have your games and not have to reinstall them all. It not going to help with the oculus client install but at least you don't have to download all of your games again..

Level 5
Yep, already done. Learned the hard way last time.
I've been trying to reinstall since yesterday, but it just keeps bloody failing.
I don't want to redownload 5 gigs 3 times in a row just to install once!

Level 2
Still not fixed.

Level 5
I've given up on playing Echo Arena at all because it fails at installing third party redistributables.

Level 2

Same here... I tried downloading Echo Vr and it was the only game that did that issue. I tried deleting and reinstalling the Oculus app but the only thing I got was 15 minutes wasted and disappointment towards Oculus for not solving this issue after 3 whole years.