cancel
Showing results for 
Search instead for 
Did you mean: 

Screen jumping randomly in the Rift

UBSERD
Level 5
It isn't judder which is usually poor optimization on the developers part I've come to find out, but it's like the screen will jump for half of a second, then resume for about a minute or so doing good, then happen again in order over and over. This also happens on the oculus home screen as well. Has anyone else experienced this, and is there a fix that doesn't include formatting my PC? I've reloaded my PC like 4 times already because of issues I've had with the rift.  
74 REPLIES 74

UBSERD
Level 5
That's great to hear wildt! The only game that seems to still give me some performance hitches is Minecraft but I think that might be more game optimization than anything. The game runs smooth at 90 frames per second but occasionally will hitch a little, very minor almost unnoticeable but I see it. With the new space warp coming out without having to change the config yourself I think all of these frame problems will kind of disappear over time. Fingers crossed. It's been a long time coming.

UBSERD
Level 5
So I've tried a couple different games since my last post and it seems that there are still issues after the Nvidia update. It seems that it is even worse than it was before but a little less noticeable if that makes any sense. I'm getting Smaller hangups but they happen more frequently now. I have noticed this behavior in casino VR poker, Minecraft and Eve. Before this last update they played fine but I still had the every 30 seconds hang up so I guess it's a toss. Has anyone noticed that all of the games are playing well now? I'm wondering if it's just something on my end, thanks.

Wildt
Level 12
@UBSERD
Sorry to hear that - my daughter and I have both played various games/demos and neither of us noticed a single hiccup since the driver update. 
PCVR: CV1 || 4 sensors || TPcast wireless adapter || MamutVR Gun stock V3
PSVR: PS4 Pro || Move Controllers || Aim controller
WMR: HP Reverb

UBSERD
Level 5
Yeah it's strange. Lucky's Tale, Minecraft and Eve Valkyrie used to be a very smooth experiences barring the 30 second hitches from the previous update, but now I'm getting little pockets of judder randomly but not as apparent. These games didn't have them before and were the "smooth" experiences.

Fredd32
Level 5
New driver cleared up my issue as well.

SauSack
Level 4
.....Driver doesn't do the trick for me. Although the judder does not occur that often, it still exist.......

UBSERD
Level 5
Ok good, i'm glad I am not the only one. The funny thing is that in oculus home now there is no hang ups at all, and even in the games that I mentioned above it isn't that noticeable but it definitely happens more frequently with less of a effect as the previous update giving the skip every 30 seconds. I'm wondering if the companies need to update the game drivers to work better with the current driver for Nvidia?

Palidore
Level 3
Found this thread and am chiming in with seemingly the same problem.  The thing is with me — and you can call it paranoia —  but I haven't updated my Nvidia drivers at all since I got my Rift.  I'm still on 361.91, so that's been a constant.

This problem, however, only seemed to surface in these last few weeks.  I've followed a bunch of troubleshooting steps online to no avail.  Then once I switched USB ports last week, it seemed to solve the problem, but as of today, the judder is back again, and it's driving me crazy trying to figure out what's going on.

Nvidia drivers have remained the same, so I'm wondering if it's a recent Windows update that messed things up, a recent Oculus driver update, or if it's a case of hardware failing somewhere :neutral:

EDIT: Okay, just a few minutes after I posted that comment, I've seemingly found a "fix" to the issue.  Go figure!  I opened up task manager, scrolled under Background Processes, and ended up closing out a process called "Stereo Vision Control Panel API Server," and lo-and-behold, the frame drops stopped.  In the Oculus performance overlay, where I was getting application or compositor frame drops every couple seconds, it's not happening anymore.

The reason I even thought of closing that process, is because one of the troubleshooting steps I remember reading, was to disable stereoscopic 3D in the Nvidia control panel.  Mine is disabled, yet I noticed that process still up in task manager for whatever reason and closed it as a shot in the dark, and it happened to help!  Fingers crossed I didn't jinx it.  Let me know if this helps any of others who are having this problem.

EDIT 2: Aaaaaaand it's back again. Kinda.  I don't know why ending that process stopped the judders momentarily, but sure enough they came back.  Keeping Chrome completely closed seems to help...maybe...but can't say definitively, will have to look at it more when I'm less tired.  Kinda spent on trying to solve this problem tonight.  Anyway I'll report back if I find a more reliable solution.

NetViper2006
Level 2
I just got mine this weekend. Hooked it all up and updated to the newest nvidia drivers. (gtx 970) and the screen is bouncing up and down in the oculus home room.  Its horrible and unusable.  I tried the power settings in this thread, but it made no difference.  

Not sure what else to try. I might have to return it.

Log_a_Frog
Level 7
I have an Amd fury. Similar issues with 1 game. It appears it is not limited to Nvidia.