cancel
Showing results for 
Search instead for 
Did you mean: 

Star Wars Squadrons and War Thunder won't load on Oculus Quest 2 with SteamVR

prodabber02
Level 2

When I try to open Star Wars Squadrons and War Thunder on the Oculus Quest 2 with SteamVR, it shows the SteamVR backdrop (the mountains and purple sunset) and a box in the middle of the screen that says "Star Wars Squadrons now playing" or "War Thunder now playing". I can hear the sounds and all and when I take off my headset to look on my pc screen, it shows the game as if it was in 2d mode.

 

What makes it so frustrating is that I can run Beat Saber just fine. 

 

I am using the Oculus link tethered to my pc.

 

Please help!

 

merci/danke/thanks/gracias/graci

1 ACCEPTED SOLUTION

Accepted Solutions

TomCgcmfc
Level 15

With my Q2 I generally find it best to go into the Oculus app and select its virtual desktop.  Then, from the desktop, startup SteamVR either from a desktop shortcut or from your taskbar if you have already enabled Steam with your win10 task manager start up tab (which is what I do). 

 

Once you are in the SteamVR void and have a library menu (you may need to click the left controller menu button) just select the Steam game you want to play.  To exit the game I just normally  click the left menu button and select exit.  Afterwards, to go back to your Oculus menus just click the oculus button on your right controller  and exit SteamVR.  Just play around with this a bit and I'm sure you'll figure it out mate.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

View solution in original post

2 REPLIES 2

TomCgcmfc
Level 15

With my Q2 I generally find it best to go into the Oculus app and select its virtual desktop.  Then, from the desktop, startup SteamVR either from a desktop shortcut or from your taskbar if you have already enabled Steam with your win10 task manager start up tab (which is what I do). 

 

Once you are in the SteamVR void and have a library menu (you may need to click the left controller menu button) just select the Steam game you want to play.  To exit the game I just normally  click the left menu button and select exit.  Afterwards, to go back to your Oculus menus just click the oculus button on your right controller  and exit SteamVR.  Just play around with this a bit and I'm sure you'll figure it out mate.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

View solution in original post

Pixie40
Level 10

Yeah, sometimes it can take a while. Another issue can be that in VR, you don't get crash warnings. Those are on your desktop, so you have to take off the headset to see them.

Lo, a quest! I seek the threads of my future in the seeds of the past.