cancel
Showing results for 
Search instead for 
Did you mean: 

auto ASW - performance issues

Syndroid
Level 7
So I was messing a bit with ASW, and so far, I'm not 100% happy with how the automatic ASW performs on my system,
In my understanding it is supposed to fix positional judder and ghosting on low fps (and also allowing lower spec PCs to enjoy VR).
While it is very good in fulfilling that promise, what it also does is reducing the overall performance (at least on my system).
I'm not a tech expert and and my english isn't that good, so I've recorded a video.




In the video you can see how I was switching between ASW disabled (ctrl+NUM1) and auto ASW (ctrl+NUM4)
As you can see, without ASW I get steady 90 fps most of the time. 
That "performance headroom" chart is scratching along 0 and dips a bit below 0 occasionally. However, everything is butterly smooth throughout this time. I only get noticible position judder and ghosting artefacts on more drastic dips(something like 87fps).

Now having auto ASW enabled, it seems to kick in way too early and I can notice the difference immediately. it is worse than the native 89-90 mode. 
In an ideal world, auto ASW kicks in at 88fps or respectively when there is true juddering.

That being said, I hope Oculus doesn't plan to force auto ASW in the next updates. 
That would be bad since I optimize most graphic-settings in a way that it is scratching along that 90fps mark and it is working just fine with ATW alone. 

What are your experiences with auto asw? 
11 REPLIES 11

Greyman
Level 9
I just leave pixel density at 1 and stick the settings up to ultra.  No stuttering yet

Comic_Book_Guy
Level 9
There's no need to disable G-sync as that will only apply to a supported display and Vsync is handled by the ap and/or SDK heppsan.