cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Horizon Workrooms (Beta) throws WorkroomsOCGatekeeperClientService error

maxcreeper360
Level 3

Hello,

I currently own an oculus quest 2 and recently installed Meta Horizon Workrooms (Beta) last night.  It worked perfectly fine the entire night. All the features were great, and it launched successfully. However, I tried booting it up this afternoon and it made me set my desk boundary and then it loaded in the loading screen for a few seconds. Then suddenly, it throws an error that says:

 

An unexpected error occurred

Failed initializing the OCGatekeeperClient

(WorkroomsOCGatekeeperClientService) service.

Please use the Oculus button to quit Workrooms and relaunch the app.

 

I tried relaunching Workrooms, reinstalling it, and rebooting the quest. Also, my quest is up to date.

66 REPLIES 66

Styr4c
Level 2

I figured out how to solve it!

You need to have Horizon Worlds installed on your headset as well. Seems like Horizon Workrooms is using a service from that app to work. You may have to run Horizon Worlds once after you install it as well, I'm not sure. I was having this issue for days and I thought to try it and it fixed it for me!

Note: This worked for me on my Quest Pro. I imagine it'll work on all headsets but can't necessarily promise that

BlueberrieSmoothie
Meta Quest Support
Meta Quest Support

Hey everyone! So sorry in the delay in responding on this thread. I know every single one of you are wanting to get back into Workrooms (Beta), and I have some good news! 

 

There was in fact a bug that some users experienced when trying to access Workrooms (Beta) from Nov 4-7. According to our team, this has now officially been fixed! The Workrooms (Beta) app should now be working as expected for all Meta Quest 2 and Meta Quest Pro users. 😁

 

For this fix, you may need to update your headset, and uninstall and reinstall the Workrooms app, so please try that first if you're still getting the error.

 

If you're still having this issue with Workrooms (Beta), please let us know (and send a screenshot if you can) so we can get the engineering team to look into it further.

Make sure you smash that Kudos button!

Hi, it still does not work for me, I still get the same error as described in the thread. Can it be that you have to have Horizon Worlds installed? The problem is that I would very much like to download and use Horizon Worlds, but here in Austria it says in the Meta Store that it will be released soon. 
Do you have a way to fix this?
 
Thank you very much.

doesnt work for me on quest 2

Here is an error from the screenshot, in German.
I also uninstalled the app, restarted the device and reinstalled the app, unfortunately that didn't help either.
The Oculus is up to date and is registered in Austria.313971035_666819934812479_5393732407538161392_n.jpg

Thank you for update unfortunately it still doesn't work for me either. Just tried on Quest 2 and Pro and same issue. Installing Horizon world doesn't fix for me either... oh and by the way Horizon world doesn't work for me anymore either... I just get the Entering Horizon World message and it hangs there ... I gave up after 5 min and quit the app. Something is really wrong guys!

I sounds even more menacing in German 😉

sorry this is me in workrooms not worlds just to let everyone know on oculus/meta quest 2