cancel
Showing results for 
Search instead for 
Did you mean: 

Not seeing Avatars on-device

phindle
Level 4
Hi,

I'm working on getting Mobile Avatars working on GearVR. I've made a Unity player build of our app, using Unity 5.4.3f1 and the 3/3 drop of the Mobile Avatar SDK. This integrated without difficulty into the existing codebase (which already supports Oculus Avatars on the Rift).

I deploy the built .apk onto my Android Phone, and boot the game using a GearVR headset.

I can then pair with the game running on my PC in the Unity Editor, set to build-platform Android.

On the Gear : I create a game room in the app, invite a friend (who's the Unity Editor player - using a valid user token), and once the invite is accepted, I know we're both present in the game room. (Just by observing our normal UI - I can see both player's usernames listed in the room).

Here's the problem:
On the PC Unity Editor, I see the Avatar of the GearVR guy.
On the GearVR though I see nothing - no avatar.

However, I've got sufficient debugging text being displayed on the Android device, to be sure I've instantiated both the local & remote avatars, and the position of the remote avatar should be correctly visible.

The network connection is solid - pose data packets are being correctly transmitted from GearVR -> Unity Editor. I know this because if I move the GearVR headset about, I can see the Avatar of the GearVR guy bobbing around on the PC in the Unity Editor. I also see that the GearVR device is receiving pose packets from the Unity Editor build. (I'm just displaying the packet sequence int, which is being incremented all the time).

Can anyone suggest why the avatar is not showing when running on GearVR? Is it shaders? DLLs or libs? Something I need to set up in Unity or the player preferences?

Thanks,

13 REPLIES 13

Ross_Beef
Level 7
hey @phindle  - by way of debugging - are you able to see another mobile Avatar when you run on 2 Gears?

Ross_Beef
Level 7
Also - were you able to see other avatars in the sample scene?

phindle
Level 4
"were you able to see other avatars in the sample scene?"

I haven't run the sample scene on-device. I will give this a go.

phindle
Level 4
"are you able to see another mobile Avatar when you run on 2 Gears?"

I'll try running on 2 gears!

phindle
Level 4
I've tried running our game with the .apk deployed to 2 devices, and neither player sees their opponent avatar.


phindle
Level 4
Progress update:
Using Win10 64-bit, Unity 5.4.3f1, Oculus Utilities 1.11, Avatar SDK from 3/3.

*** TEST SCENE SETUP STEPS ***
Create fresh Unity project
Import Oculus Avatar SDK .unitypackage
Import Oculus Utilities 1.11 .unitypackage
Set our GearVR App ID in the config menu
Open RemoteLoopback scene and position the RemoteAvatar a bit further back (to make more visible)
Change build to Android
Hack Start() function in OvrAvatar.cs to supply a known Avatar id. (Id for phindle in fact 🙂
Build settings. Add current scene. Build an .apk.
Deploy to device & run with a GearVR.

Result : Avatar appears in the TEST scene, with phindle's customization all present and correct. Movement of GearVR headset is correctly reflected on the RemoteAvatar in the scene - phindle avatar moves in sync with the real-world me.

I also tried the same process with the origin Tracking Type set to both 'Floor Level' and 'Eye Level'. I get the same outcome as above (i.e. avatar appears) regardless of the origin Tracking Type.

So : Avatars appear OK in a test scene, but still not within our game.
It must be something in our game setup... I'll continue to investigate.

Ross_Beef
Level 7
I'm strongly hoping you weren't working from 1:24am to 6:24am

phindle
Level 4
@Ross_Beef - I'm in the UK, I'm soundly asleep during those hours 🙂

Ross_Beef
Level 7
Is there an easy way to share a code sample?

This isn't impacting all of the beta developers, but it is impacting 2, so good for us to look deeper into this.