cancel
Showing results for 
Search instead for 
Did you mean: 

Inflate error causing hangs

crammy360
Level 2
Hey guys,

I don't know if this is specific to GearVR, but we seem to get one of these 2 errors when we load a level:

- Inflate Error: too many length or distance symbols
- Inflate Error: invalid stored block lengths

The errors seem to happen at somewhat random (We've had it on the first time we've loaded a level) but normally happens after a number of times we load levels.

We've had the game running without putting it in the device (by turning on the Developer Mode on the Note 4) and we don't seem to get any errors.

The errors cause our game to hang on a black screen (since it failed to load I guess) and becomes unresponsive.

Our game has been developed using Unity and we have the latest phone binaries and updates.

If anyone can offer any help or advice, it'll be greatly appreciated.

Andy
6 REPLIES 6

cybereality
Level 15
Can you provide the full log file (logcat)?
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

crammy360
Level 2
"cybereality" wrote:
Can you provide the full log file (logcat)?


Sure thing

I've had to trim it a bit, the error spams the log over and over so I removed the vast majority of them so the log isn't completely swamped with the same error message

IronMan
Level 2
Have you seen this Unity forum thread?

http://forum.unity3d.com/threads/android-game-crashes-on-scene-loads-inflate-error-signal-11-sigsegv...

Are you loading any enormous textures? Are your Player Settings all correct? Is your AndroidManifest file set up correctly? An editor.log from the build process might be handy to see what's going into your apk files. I always recommend reviewing that file occasionally to catch any "oops..why the heck is that texture/animation/asset/etc included in the build"

You could be running out of memory on scene loads.

crammy360
Level 2
It looks like we have managed to fix it (or at least not been able to reproduce it anymore).

Turns out we needed to tell Unity to actually removed any unused assets from memory before any level load, which I thought would have been automatic.

I'm still a little suspicious if this was truly the problem, but it seems to have fixed it for now.

IronMan
Level 2
I just noticed this in the Unity patch 4.6.1p1 build notes and thought of this issue:

Android: Fixed a file-loading problem which occasionally caused 'Inflate Error' messages & freezes or crashes when loading resources on Android


download here: http://unity3d.com/unity/qa/patch-releases

Hope it helps..

-andrew

crammy360
Level 2
The bug had come back (looks like we only really made it less likely to happen and not actually fixed it), so this should help.

Yay!