cancel
Showing results for 
Search instead for 
Did you mean: 

No Audio In Unity Build Without Tabbing In and Out of Application in Go

Halfspacer
Level 5
Hi!
I don't know what's going on, but as I was working on my project and pushed the latest build to my Oculus Go, I noticed I didn't have any audio. I pressed the Oculus-button and pointed my controller at the menu buttons -- Sure enough, the Oculus UI had audio. So I tabbed back into my app and low and behold; The audio was restored (and seemingly 'caught up' to the game as all the gun sounds that were missing before all played at the same time in a 'big bang').

What I've tried so far in my troubleshooting efforts:
* Different audio files, formats and import settings. 
* Blank Unity project. 
* Using Oculus Spatializer plugin as well as None. 
* Different Unity versions (2017, 2018 and the latest 2019 alpha)
* Both the Oculus Utilities 1.28.0 as well as most recent 1.30.0. 
* Factory Reset of my Go (Old builds and other apps run fine). 
* Reinstallation of NDK and SDK. 
* Different Target and Minimum APIs. 

I also ran LogCat which didn't show much except for
ActivityManager: RestoreAudioRecord called for pkg:com.oculus.vrshell 
ActivityManager: restoring op audio record to 0 for pkg:com.oculus.vrshell
Which I assume is from when I tab back and forth.
Does anyone know what the issue might be? I feel like I've tried everything at this point .___'. I'm sure it's something super silly that I keep missing. 
3 REPLIES 3

nielshoog
Level 3
Hi, Same problem here!
I have found several (not many) users who experience the same problem. We have several go's in use en all with the same problem..
I think it has to do something with the firmware update .. because last month it worked fine (with the same APK and settings) Or have you already found a solution?

Halfspacer
Level 5
It's been working okay for me so far. I created a blank project, imported 1.29.0 of OVRUtilities, and somewhere between fiddling with Mono/IL2CPP backend, switching back and forth between it and runtime version between 3.5 and 4.x it started working. 
Honestly, this all started when I first installed OVRUtils 1.30.0 from the Unity Asset Store. I deleted the Oculus folder and installed 1.28.0, which didn't fix it, but I suspect there might have been other files involved, or some project settings were changed on import. 

nielshoog
Level 3
Hmm that does not seem to work for me. Switching between 3.5 & 4.x seems to reduce te problems but I am looking for a workable solution. 

Which oculus version do you have?