cancel
Showing results for 
Search instead for 
Did you mean: 

‘Not supported For Your Device or OS’

SamVickery
Level 2
I have released an app to the alpha channel but it is appearing as ‘Not supported For Your Device or OS’ on the device. I can install the apk to my device manually. I am using Unity and the mobileSDK. Has anyone got any ideas on why the app is appearing as not supported on oculus home?

Thaks
Sam
11 REPLIES 11

ayo1103
Level 2
I have same issue here,
It's show 'Not supported For Your Device or OS' on my Galaxy S6 in Oculus Store

Model number : SM-G920P
Android version : 6.0.1

I'm using Unity 5.3.5f1

Anyone can help us?
Thanks

Ayo

circosvr
Level 2
I have the same situation, too.

My devices is Galaxy S6 edge, Android version is 5.0.2, and Oculus Home version is 2.23.9.
I use native sample, Oculus360VideosSDK, to learn the submission stuff.
The application works without Oculus Home.
However, I get the same message after I modify the AndroidManifest.xml settings and upload to alpha channel.
I tried several mobile SDK versions among 1.0.0.1, 1.0.3, and latest 1.0.4. Unfortunately, none of them works.
It shouldn't be OS version problem because I check the variables in latest xml file, android:minSdkVersion="19" android:targetSdkVersion="19", which is 4.4 APIs.

Do I miss some setting variables?

Thanks,
Ken

irmike
Level 2
Did anyone ever figure this out? I'm having the same problem.

VReel
Level 2
same problem here - any solutions?

adrianhatch
Level 3
I am also encountering this issue. Hoping someone from Oculus can resolve since I am on a deadline and there are multiple unanswered threads about this. I will update if I find a solution. I'm using the Oculus-provided BuildManifest xml and project settings with a Galaxy S6. I have previously built this project without issues directly to my device via USB, and unlike the commenter in the other thread I do not have sideloaded versions already installed.

ajnelson
Level 2
Similar issues, similar short deadlines. 5.5.0 f3 Unity. Manifest and unity settings are API level minimum 23, target 23. S6 6.0.1 will work with a sideloaded app, but releasing it to the alpha channel, we also get the not supported device or OS. 

Interestingly, when I click Build Status column "Complete" for that build, and then click Build Details, I get this
6qznab9rznbz.png

The only thing that stands out is we've definitely set the minimum and target to 23, which is what 6.0.1 should support. Target is shown as 24. Either way you'd think minimum would be supported. I have no idea if this is the real cause though. 

We've tried this both with and without uninstalling the previous sideloaded version. We need a solve on this! 

Andrew

juanoldinho
Level 7
When you are releasing to a specific channel you need to be sure your Oculus ID is part of that release channel. 

For example if I were to release my app to my Alpha channel for the first time I would have to add my Oculus ID, juanoldinho, to the list of users for that Alpha channel.
Please tag me, @juanoldinho, in your forum post/response if you need immediate assistance or want additional support or context on an issue you are having with our software or integrations.

Having an issue with our platform, services, or integrations?

Try using our new bug tool to report this and receive emailed updates as we proceed to address it internally.

Mr_OculusChina
Level 2
I'm having the same issue.Have any solutions?My deadline...

Flo13
Level 4
I'm having the same issue.

Unity 5.6.0b8
Galaxy S6
Android 6.0.1
minSdkVersion="23" and targetSdkVersion="25"