Showing results for 
Search instead for 
Did you mean: 

Oculus Go Development - Failed to Install Problems

Level 3
So we haven't been able to install our app which is on the ALPHA Channel. We've recently upgraded Unity from 2018.2 to 2019.2.13f1 and Oculus' SDK tools from 1.32 (All the tools were on 1.32) to Oculus' SDK 1.48 (presumably v 15, we've noticed a fragmented naming convention with this now - but it is Utilities v1.47.0 / OVRPlugin 1.47.0 and SDK 1.48.0). Initially I thought it was perhaps the Oculus servers just not responding or something but we waited over the weekend and it's still an issue. Everything is passing, we can upload builds correctly through the CMD line tool, and even install by side loading the app without any hitches. 

However, we're getting the feeling that it's due to the 'Additional Validation Test Results' coming back with that somewhat limited result message: 'This upload includes a library from an Oculus SDK newer than 1.41, which is incompatible with Gear VR.'. Is there something specific that we should be checking off inside of Unity? I can't seem to find anything that is ONLY for GearVR since it's always combined with the Go in most instances.

Attached below is going to be the OculusProjectConfig inside of the Oculus directory within our project:


Here is screenshot of our OVRPlatformToolSettings inside of our Resources directory of our project (outside the scope of the Oculus directory):


Inside of the OculusPlatformSettings we've got everything configured correctly there for the Oculus Rift ID + Oculus Go/Quest or GearVR ID. Should we generate another App ID? We'd rather not have to do this if it's not necessary (which I don't think it is). Otherwise, here is our Android Manifest file. We have generated a new one to test to see if that was the issue - so far it is not. We removed the meta-data android:name="" android:value="vr_only" to see if that was the problem and it still has persisted:


We do have a BETA Channel going with our project before we upgraded Unity + Oculus and we've tried to re-install that to see if it works and it does. Everything is coming down to this upgrade in particular and we would like some guidance on what we're supposed to be removing/checking/etc. within our project to get this to stop referencing anything of the GearVR. We have never built for the GearVR specifically and have no users using that platform to access our app. Any help would be greatly apprecitaed!

Level 3
So I've tried to publish an app using a brand new Unity project (2019.2.13f1 as per the Oculus recommendations) and using the Asset stores Oculus Integration SDK tools (v 1.45). None of it has our projects codebase in it and is only using the Oculus demonstration scene(s). I've tried using the SocialStarter project as that was the base of our current project. I've went through all the steps of hooking up the Application ID, Android Manifest file, and the whole 9. However, once I push the project up to Oculus' servers I'm still getting the same validation problem(s). I still can't install the app on the Go in the ALPHA channel that we used to be able to. 

Anyone out there successfully pushing to Oculus' servers with the Go in mind with the Unity + Oculus SDK tools at those versions? Thanks in advance for any replies.

Level 3
I figured it out - turns out that Unity (probably) signs the APK's for you now. In the older versions that we were building we had to manually sign them once we had built the APK out. Hope this helps someone else out that upgraded as this was just second nature to us when we were ready to upload our APK's.

Level 3
Hi! i have the same problem. How did you solve it concretely?  thanks very much!