cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link Needs To Be A Seamless Connect Just Like VD

LameDuckWarrior
Level 6

Currently Air Link requires unchecking and rechecking Air Link on the PC app before it shows in Quest 2.

Some of us are not directly in front of our computers when connecting.

5 REPLIES 5

Pixie40
Level 9

Even worse if you're trying to use Air Link to replace a physical monitor (which I've tried experimenting with)... it turns Air Link off on your PC unless you use it every single day. What if you can't use your computer due to lacking time for 2 or 3 days?

Lo, a quest! I seek the threads of my future in the seeds of the past.

Nunyabinez
Level 8

Uhm, you guys did notice that you enable it in the EXPERIMENTAL section on the headset and the BETA section on the Oculus app didn't you?

i7 8700, 16GB, RTX 2080 TI, Rift CV1 | i5 4690K, 16GB, GTX 1660 TI, Rift CV1 | Quest | Quest 2

Pixie40
Level 9

Yes, we did. And this new feature so far is broken. As is, apparently, Oculus Link. And Oculus Link is not an "experimental" feature anymore.

 

I don't know about anyone else, but I can't get Air Link to work even though my system is more then capable of running it. I even just bought a new router just for running this service. And the app crashes immediately every single time. it might be amazing, it might be meh, but that would require it to actually work.

Lo, a quest! I seek the threads of my future in the seeds of the past.

I am always amazed at people who say "I can't make this work so it is broken." Link works flawlessly for me. Airlink works flawlessly for me. VD works flawlessly for me. And the same is true for millions of others.

 

I'm genuinely sorry that it is not working for YOU, but it is not broken.

 

And if you have feedback for Beta software you should send it to the developer. I'm quite sure that we won't have to re-enable it every time we restart once it is out of Beta.

i7 8700, 16GB, RTX 2080 TI, Rift CV1 | i5 4690K, 16GB, GTX 1660 TI, Rift CV1 | Quest | Quest 2

Pixie40
Level 9

Maybe it's not "I can't make this work so it must be broken" so much as "It WAS working, and now it's not even though the only thing that has changed is that Version 28 has been patched in on both desktop and the Quest 2". Which is the case with Oculus Link for me, and many others. If a PC is capable of Oculus Link (which mine is), and you have a good enough wifi router (which I do now) then Air Link is suppose to work. If it's not working for a good number of people who it should work with, then perhaps there might be an issue?

 

Perhaps you should turn that around @Nunyabinez and realize that just because you aren't having an issue, that doesn't mean nobody else is. But hey, since you seem to have all the answers, try explaining the fix for this:

  • GPU is a supported one, a Radeon RX580 (2 of them, actually... yes I have crossfire disabled for all VR)
  • Brand new 5ghz router with only that channel in use
  • Computer tower is plugged directly into the router via the ethernet cable that came with said router
  • Quest 2 headset and desktop app are both on V28
  • Quest 2 detects and easily connects to desktop
  • When I try to launch Air Link it starts loading, then crashes. Every. Single. Time.

Is that a case of my system not being capable, or is it a case of "Hmm, maybe there is something wrong with Air Link"? By the way, Oculus Link broke as well for me with V28. I'd been having issues with using the virtual desktop that's built into Oculus Home (PC), but other then that it worked fine before V28.

 

Oh yeah, as for Oculus Link, here's the troubleshooting issues for that. Maybe you can figure out the magic fix to what you are positive is user error.

  • Once again, GPU is a supported one (Radeon RX580)
  • I have the official Oculus Link cable, which was working just fine for Link prior to V28
  • The link cable is plugged into a USB-C port, the same one I was using before
  • The Quest 2 detects that it's plugged into my PC and asks if I want to enable Oculus Link
  • When I try to enable Link it crashes back to my Quest 2's home every single time. Every 4th attempt I get a popup telling me that Oculus Link keeps crashing and prompting me to close the app after it crashes

So, what's the "user error" problem that is keeping it from working? You know, since it must work flawlessly for everyone because you apparently got it working. Note, that I have been incapable of using Oculus Link since my desktop first updated to V28, due to the headset still at the time being on V27. And now it still doesn't work.

 

EDIT: Sorry about that. I'm kind of cranky right now. I've spent all day fighting with Oculus Link and Air Link trying to get them to work. I've looked up everything I could, and everything I can find says that it should be working. All my settings are correct. My hardware meets or exceeds the requirements. And I even spent $80 on a brand new wifi router just so I could use this new feature. Only both Air Link and Oculus Link aren't working. They just keep crashing endlessly.

Lo, a quest! I seek the threads of my future in the seeds of the past.