cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link cannot find PC

Clurtyx
Level 2

Imma keep this as short as possible.
I got a new 5GHz / 2.4GHz router so I could use Oculus Air Link without it stuttering every five seconds (my previous router only had 2.4GHz). When I try connect to my PC it just says "searching for device" but cannot find the PC. I have been troubleshooting and looking at forums and reddit posts for the past few days but none of the advices I have found so far have helped me. I found out that if both devices [the PC(in this case an old laptop I found) and the Quest 2] are connected to Wi-Fi, instead of the PC being connected to Ethernet, Air Link can find the Device and it works without problem. But my PC doesn't have a Wi-Fi adapter, and even if it did I do not want to use Wi-Fi on my PC for Air Link.
Here's a list of everything I have done to try and fix this issue:

  • Turn both devices off and on again
  • Turn Air Link on both devices off and on again
  • Uninstall the Quest app and install it again
  • Turn off my Firewall
  • Port forward the port 5669
  • Change some stuff in my registry
  • scream at my pc for 10 minutes straight
  • Disable DNS Proxy in my router's settings (Not exactly sure what it does but I thought maybe that could be the reason. It wasn't)
  • Turn off all anti-virus programs (A.K.A. Windows Defender)
  • Change from 80MHz to 20/40MHz in my router's settings (like I already said, the problem isn't the wi-fi but the ethernet)

I'm really desperate for help. My Oculus Link cable also started to act up yesterday and replacing it would cost too much for me right now so I *really* need to fix Air Link. Thanks in advance!

17 REPLIES 17

No, I still can't get this working with Air Link.  Virtual Desktop works just fine though, which proves it's not a router or networking problem.

That probably just means your wired network and your 5GHz wi-fi network are different subnets.  It shouldn't be necessary for the PC to be connected to the wireless network at all.

tibik2
Level 2

I had the same problem but it worked fine after I switched over to the 2.4 Ghz network.

 

I have a wifi 6 router but my computer does not support wifi 6. Then i disabled the wifi 6(ax) protocol on the routher, and then it worked fine on the 5 Ghz band as well.

 

It seems like the oculus quest are unable to communicate with a computer using different wifi protocols even though they are connected to the same SSID.

tinycatmom
Level 2

still can't get it to work and seems that maybe in the current edition of the app there's no longer dev mode. Can't find it anywhere. Such a shame at how much they downgraded the Quest 2 from both the quest 1 and rift to be basically junk

You need to register developer status first. It takes two seconds and then it'll be in the app. Just doing this didn't fix my issue though. I've tried a whole laundry list of things and still nothing. Pretty weird.

LeonLionHeartYT
Level 2

Holy crap I just figured it out.

 

If ANY other app is using a UPNP on your PC it will not allow UPNP traffic to go to the Oculus. Basically, there's another App actively using port 1900 outbound from your PC. In my case, Samsung Dex was using port 1900 to broadcast traffic. Oculus was also trying to use port 1900 and of course, it was getting halted because it was already in use. HOPE THIS HELPS!

Having the same problem. Do you reckon if I don't have UPNP enable it won't work, as I am having the same issue?

 

I can't see anything which would be using these ports. It seems to work with the PC on WiFi but not wired.

guilder13
Level 2

Looks like it's just an AirLink bug. And it doesn't really matter what are you trying, it will just start working some lucky day (or don't). I have problems with AirLink for more than a week already. Everything from this post and many other posts I have already tried. Once it started working after turning on and off the public beta channel option (basically reinstalled the app). After two days my PC just disappeared from the connection list.

Also, I can connect to my router either by WiFi or Ethernet, with no differences.

I have DeveloperHub installed, but Airlink worked with it before.

Anyway, looks like oculus just uses some unreliable way to find a PC. And they don't provide information about conditions for the feature.