Showing results for 
Search instead for 
Did you mean: 

Air Link "Searching for Computers....." Permanently - no results, no errors.

Level 2

Yes I have the Oculus PC App open with Air Link selected. 

Yes I have tried rebooting headset and PC.

No there is nothing wrong with my network, it is PC > Router (via ethernet) and headset is connected to that router. It works flawlessly with Virtual Desktop.


What else can I try to get it working? I've tried several times, left it for long period and it does nothing.




Level 5

You have to first make sure that your PC and Quest 2 belong to the same Private Network.


Next, you have to turn on Network Discovery for your Private Network on your Win 10 Network and Sharing Center.


Your Q2 headset and PC should now be able to pair with each other.

Level 2

Thanks but that's already the case.  In Deo VR I can see my PC files.

Not applicable

Have you enabled it in the Oculus Software on your PC or Phone 

In the Beta settings ?

It should detect your PC there.

EDIT ... Sorry i misread your post ... that is the bit your referring to 

Jesus Christ. I'm so glad I'm not the only one experiencing this. All I see is people complaining about issues that there are already answers for and posting about it on Reddit just gets ignored and/or downvoted.

The Oculus app is showing the PC name.


Tried it again today after everything's been switched off overnight and still doesn't work. Also tried disabling windows firewall.

Are you saying you are experiencing the same problem or that you know what the answer is? 

Level 2

My VPN was the problem - no idea why.


Connected but it's unusable, screen all over the place and several seconds of lag. Back to VD.

Level 3

I'm having the same problem and it's not a VPN issue as I do not have one set up. Rebooted headset and computer, signed out of the app and restarted oculus service.  PC is on a static ip. Headset is on the same network. 


Private network with discovery turned on. Firewall disabled.  Virtual Desktop/File Browser/Media players all work over wfii. Not in public test channel. Air link turned on in both headset and PC Oculus app. 



Level 4

same problem here