cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link stutter only on 72hz after upgrading to RX 6800

ragp13
Level 2

I am experiencing choppy movement or judder with my Quest 2 via Air Link since I upgraded from my 5700XT to a RX 6800. Used DD to uninstall the old drivers and am currently using Adrenalin 21.4.1 

 

Movement (turning head, moving hands/objects in front of me) leads to a second (ghost) image that trail slightly behind the main image. As a result, movement feels jittery and it looks unsharp. This was not the case when using my 5700XT.

 

Stationary, everything looks sharp. The choppy movement only occurs when I move (something).

 

According to Oculus Debug Tool there are no dropped frames and I am easily reaching 72fps all the time with performance left. The Air Link connection itself is also stable and fast (set to 100mbit/s). However, the Oculus Debug Tool overlay itself jumps around when moving my head.

 

This is happening both in SteamVR as in the Rift Home / Air Link dashboard, and not when running VR apps on the Quest 2 itself.

 

Turning off ASW had no noticable effect.

 

Interestingly, what did have an effect was changing the refresh rate from 72, to 80 or 120hz. At 120hz everything was perfectly smooth. At 80, it was almost perfect with occasional stutters. At 72 it was constant stutters.

 

120hz isn’t really an option given the performance hit. And the 72hz is simply unplayable. However, 120hz with AWS kicking in to limit it to 60hz still gave a smoother experience than 72hz!

 

Wired (regular Link) was perfect. Even with 72hz.

 

Anybody have a clue what might be causing this Air Link stuttering at 72hz? It seems to be a specific movement related feature that's not working propperly?

5 REPLIES 5

ganapoly
Level 2

As a simple solution, symptoms disappear while recording screen with amd adrenaline encoder. But this is not a fundamental solution.

Nytevizion
Level 4

Set your encode width bitrate to something like 200 or higher. 0 gave me crappy results.

Try reducing the FOV mirror to .75 for both horizontal and vertical. That should boost your performance enough to allow you to use 80-90hz. The edge of the field of view is still out of range to notice with your eyes.

Using a 6800XT here. Airlink settings as follows

Also: Using the latest 21.7.1 AMD drivers and the LATEST beta Oculus package. 31.0.0.47.507

Untitled-1.jpg

Nytevizion
Level 4

Just more information I forgot about.

When I use 120hz and set the Encode width to 3664, I get a constant stutter or ghosting on close objects, (hands, menus, etc.) You can see it right away when you enter the Link room in the headset.

 

In order to fix this I have to reduce the encode width to 0 or 2784.

Thanks for the suggestion but 21.7.1 Drivers fixed the issue for me while keeping all the other Oculus Debut Tool settings as default!

Nytevizion
Level 4

Debug tool at default means you're missing out. Low distortion curve, encode width increase and FOV reduction should be a standard tweak. Better image quality and 25% more performance headroom is a no brainer.

Edit: Okay I just checked it, and I exaggerated. It's really a 15%-20% improvement depending on the game.