cancel
Showing results for 
Search instead for 
Did you mean: 

Allow Access to Data - question about don't show again

Dan_Zen
Level 3
The quest has an Allow Access to Data prompt when you connect to a PC.  It then has a grey Deny and a grey Don't show again and a blue Allow.  I want to always allow the quest to access data.  What will the Don't show again do?  It is a real pain to take off my glasses, put the quest on fiddle with controllers, then take the quest off put the glasses on, etc.  I am concerned, however that because the greys match that if I say Don't show again, then it will not allow data access and never ask me again - unless I reset my quest and lose all my data like has happened before.  I love the Quest - I do!
37 REPLIES 37

JETJOOBOY
Level 3

I have been wanting an answer to this but I don't know how to word it..

KUDOS to YOU for getting the answer into a succinct single sentence..

I hope we get an answer.. 

I have GLasses and a DODGY USB cable (I have spent a fortune on them but I have one dodgy cable left that is 50CM long so by the time I have powered up the controller.. confirmed access and popped it gently back next to my PC.... it has 70% of the tme disconnected and reconnected ... ) also I keep getting JAVA issues whilst backing up... I am told this is due to bad cables....

Please don't tell me to buy better cables.. I have bought MANY cables claiming to be USBC Data cables and hi POWER cables.. some charge the QUEST.. NONE work reliably on DATA ...

SICK OF THIS.

EXACTLY.

THE OTHER REASON is to ALWAYS allow ACCESS... I mean. .. It doesn't stop it CHARGING the thing ANYWAY..

although, depending on the RIP OFF Cable that one spent top money on... may make a difference to THAT issue!!

 

AAAAAAAAAAAARFHG

On what the oculus or on pc im so confused 

idklolshutup
Level 2

I'm having trouble DISCONNECTING it lol! I've been researching for so long, does anybody have a fix??

Jack_2990
Level 2

try going to developer options, and uncheck allow usb connections via confirmation dialogue, it worked for me

 

SublimeStudios
Level 2

For everyone still struggling with this: here's my solution to get rid of this repeating message.

 

The problem is that you have to authorize your Oculus with ADB, and once that is done you can simply switch off the usb message and a new world order of rest and peace will settle upon your soul.

 

1) First you should install the Oculus ADB Drivers 2.0 and add the platform tools:

 

https://developer.oculus.com/downloads/package/oculus-adb-drivers/

 

https://www.youtube.com/watch?v=cD6zsHQdoXY

 

2) Unplug your Quest from your PC's USB. Wait 3.14159265359 seconds precisely (just kidding). Plug your Quest back in again.

 

3) Now enter 'adb devices' in your command line prompt. It should show your device and behind it 'unauthorized'.

 

4) Mount your Quest (put it on your head). Now you should see that other message that allows you to ALWAYS access your Quest through your PC's USB connection.

 

5) For the second message (which you have been seeing thousands of times until now and which drove you to near insanity) just click 'Don't show again'.

 

6) Now enter 'adb devices' again and if correct, your Quest is now 'authorized'.

 

7) Unplug your Quest and plug it in again. You should get no prompt in your Quest and 'adb devices' should still should your Quest as a registered and authorized device.

 

8)) If any of this fails, reboot your Quest and try again.

 

9) If it still doesn't work for you then this tutorial doesn't work for you, sorry.

1. Regarding "Oculus ADB Drivers 2.0", how do I install that? I'm using macOS. It seems that the page you linked, assumes another OS of sorts.

2. I connect the cable and run "adb devices", but my Oculus Quest 2 listed does NOT display as unauthorized. Still when connecting the cable, I am prompted the dreaded "Allow access to data bla bla".

what do you mean manually enable it? its not anywhere In the settings. when i connect the headset to my PC nothing happens because i clicked don't show again and there's no option to connect it