Showing results for 
Search instead for 
Did you mean: 

App sharing not listing shared games

Level 3

Major problem and product malfunction.


We have 2 Quest 2's in our household and I am the primary account on both headsets.  We have been sharing games like "Settlers of Catan", "Acron", and "Robo Recall" to name a few. This has been a great feature for us over the last few months and the only reason we purchased a second headset. 


I purchased a new game Today to play with my wife called "Demeo" (yes it is listed as a game that has app sharing enabled, refrence linked here).  I am well aware that only certain games (apps or whatever) are capable of the app sharing feature. If you tell me this, you have not read my post entirely. Do not be stupid, I am not patient with people who suggest bad advice that is irrelevant to the problem.


After purchasing the game we went to install and jump in to play.  The game wasn't showing up on my wife's account and Quest 2 which has app sharing enabled. I then put on my wife's Quest 2 on and went directly to the game "Demeo". I could purchase the game again but said it had been shared with a link to see it in my library. This didn't work and the game still wasn't listed as a shared app that could be installed.  


I then proceeded to find solutions online to this problem and sort out a way to fix this. There were 2 ways to try and fix this:  

  1. Go through the process of removing the secondary account and disabling app sharing, then reenabling app sharing and add the secondary account again.
  2. Factory reset the headset and start fresh. 

Both of these options failed. I am not upset that we couldn't play together with our new game, I figured it would be something fixed in the near future and we would play it then.


What I am upset about is that the games we used to play together are now not available to be reinstalled. All games that are capable of app sharing cannot be installed on the secondary account. They were once there, and since I went through the process to try and fix this, they are no longer installed. We've lost our shared games.


Please fix this immediately. There has to be a solution, update, squash the bug, or whatever.


Thanks to any or all that have found a viable solution to this problem.


Accepted Solutions

Level 5

u/Ihavesubscriptions on Reddit found a fix!!!

Here is the step by step:



You need a secondary mobile device (tablet or phone)

1. Factory reset headset. This can be a second or first headset. Doesn’t matter. If it’s a second headset make sure the headset is connected to the ADMIN mobile oculus app so that you have 2 devices listed.
2. Reset experimental features and restart.
3. Set up the device for app sharing as usual.
4. power down device
5. set up one of your mobile devices to have the secondary account on it (oculus mobile store app) - not paired with the device.
6. go to browse all apps in the mobile App Store (not on headset). Change price to free in the drop down at the top
7. ‘purchase’ aka hit get a bunch (some people have reported it does not work with less than 5 free apps) you know for a fact have been purchased on your main. It will queue them up for installation but not start the downloads.
8. Start up headset and log into secondary accounts and VOILA all the shared apps should show!

View solution in original post


Level 3

I'm having the exact same problem. Started happening right after my update to v29. My secondary account is also still showing the old system UI from before the v29 update. 

Level 3

Good luck - we've had the same problem for about a week as have a lot of others.  Oculus Support has been NO help whatsoever and keep saying 'we haven't heard of any issues like this'..... 😞

I haven't looked but there should be a way to go to the previous UI or update, then download and install the stuff I want to be shared. Then go back to the current version.  I'll do some digging and let you know.

Well, this is a problem, and ignoring it won't do anything. "yeah no problem here" is not listening to your clientele and potential future clientele. Cancel culture can straight up destroy a thing if that's what they want.

Level 5

Same exact issue 

Level 2

I’m having the same issues. Previously, all apps other than Beatsaber worked on the shared account, now none work… not even free apps.

Level 3

Same issue here.  Wife's apps are no longer showing on my (shared) account.

Level 3

No replies from oculus this is sad

Level 3

I have the exact same problem, no shared apps on the secondary account. It never worked on the Q2 but I can confirm it's also not working on the Q1 since v29 either. I also noticed that the second account has the new UI but the main account has the old UI. Very odd.