cancel
Showing results for 
Search instead for 
Did you mean: 

Black screen with Oculus Link virtual desktop (not Virtual Desktop app)

Thoort
Level 2

Hello guys!

Problem: when i activate Oculus Link and i click on the virtual desktop (not the Virtual Desktop app), i get a black screen on the window but i can see my mouse and move it. I really would like to be able to use properly this virtual desktop from Oculus Link.

Labtop: Asus Tuf Gaming x550, with Windows 10, NVIDIA Optimus (AMD Radeon RX Vega 10 Graphics + NVIDIA GeForce RTX 2060), a AMD Ryzen 3750H processor, 16GB RAM.

Device: Quest 2

Already tried: to upload all the graphic and usb drivers, the Oculus software, to restart them, to restart my computer, to turn off the AMD Radeon RX Vega 10 Graphics, to force the high Nvidia graphic performances on all the Oculus related applications i found (see attached)...

Do you have any idea to fix it?

Regards, Thoort

s44lmq7dv6kw.png8m2g6x94e0ko.pngin0q5h3l3v3l.pnggx2d8a3bu4uy.jpeg6h9ffrouvjgu.png

29 REPLIES 29

This fix worked fine!

Thank you!!!

This worked! Thanks!

YahyaChehboun
Level 2

did you ever figure this out 

Yes fix is here: https://youtu.be/H_WbAHVV7o4

Pixie40
Level 10

I was having that problem with V25 through V27, I think. Made Link virtually unusable for me since half the time I'm using it as a VR computer monitor instead of my physical monitor for one reason or another. No clue what the problem actually was, but V28 fixed it for me.

Lo, a quest! I seek the threads of my future in the seeds of the past.

SanCity
Level 4

I tried setting OVRServer_x64.exe to "Save power", but then link wouldn't start at all. Just an entire black screen (OculusHome2.exe (the Unreal application)) didn't even start at all.

BUT! When reverting the setting (and closed all Oculus processes in the Process manager and restarted Oclus and reanabled the Oculus Link switch in the Beta tab, and the reconnect in my Quest 2), I start trying to resize the black window (in the now working Oculus Home environment). And by dragging and resizing a bit using the grip button and the joystick, after a while I somehow manage to drag out a second window. A window showing my computer screen! Then I could close this extra black window and be a happy man, loocking at myc computer screen, like I was using Virtual Desktop (an app that always works btw, but cant use it due to it's lack of an OpenXR runtime support currently).

Tried it multiple times, and could find what movement triggerd this extra correct window. But sometimes it worked after maybe 10s of fiddling, other times I could try for almost 2min before it appeared. Very strange.

What didn't work was showing alerts / overlays in Unity editor (but this is something that usually doesnt work with other screen sharing apps either, so probably not related)


Raton21
Level 2

I have the same problem, since I bought the quest and tried link/air link. I didn't care much then, but I want to at least try some pcvr games.. Or at least have desktop screen.  I have NTB with integrated intel graphic and GTX 1060 (I know it's bad, but..  It can run something..)

 

None of the solutions I found on YouTube/google/Reddit/this post work...  I guess I will buy virtual desktop app and see if that works..

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there. This does not sound right and we want to help figure out this black screen problem with you. We do appreciate you going through so many of the trouble shooting steps and at this point, we would recommend submitting a ticket, after which a member of our team will get back to you as quickly as possible. We look forward to hearing from you.

I'm not sure if I'm being helpful or not, but I'm having the same issue on ROG G713QR.
(Asus laptop with 3070 GPU, Ryzen 7 CPU)
The common "fix" is forcing OVRServer_x64.exe to use internal GPU.
However, for me at least it also causes Oculus Link home to lag like crazy, making it nearly unusable.

I can use Firefox etc. just fine if I launch them from the "+" panel, but anytime I try to open my desktop as a floating panel it's just pure black + white cursor.
If I move my cursor around I can even see it change into the text cursor when it passes by a text field.

So it's clearly recognizing all the objects in there, it's just not rendering anything else besides the cursor.
Note that gaming laptop manufacturers typically recommend that we use older GPU drivers, as newest ones may cause issues with Asus Armoury Crate etc.
This could also be a part of the problem...
While searching for answers I found mentions of this issue even from 8 months ago.
It's a little disheartening that such an issue has been appearing and disappearing for people for so long.

Edit: Also if I connect to Steam VR with my Oculus Quest, I can use my desktop through it without any issues.