cancel
Showing results for 
Search instead for 
Did you mean: 

Blade and Sorcery oculus link

SavyFN
Level 2

I started using oculus link and got blade and sorcery, I opened the new update and the right lens seemed to be black except for the guardian. Once I loaded into the game all I could do was open the book and move the right controller. Anyone else having this problem or have a fix?

5 REPLIES 5

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey SavyFN,

 

We see you're experiencing some Link problems while playing Blade and Sorcery. If we can, we'd like to help out and see if we can narrow down the issue.

 

To do that, we'd like you to answer some questions:

  • Does this happen inly in Blade and sorcery? Or do you often get black screens in the right eye.
  • When did this problem occur? Has it always been this way?
  • Have you tried uninstalling the game or any other troubleshooting steps already?

We're going to do out best to help you out. Feel free to reply to this post so we can get you back gaming.

It only happens when using blade and sorcery, just started in the new update. I will try uninstalling it. Thanks!

OculusSupport
Oculus Community Manager
Oculus Community Manager

Of course SavyFN!

 

Please let us know if that fixed the issue or if the problem still remains.

I uninstalled and reinstalled, problem still happening.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Thanks for that, SavyFN

 

We did do some research and wanted to ask if are you using any mods? It appears some members of the game's community are reporting that you need to delete all of your mods to successfully play the new U10 update.

 

Should you not have any mods, or have already tried uninstalling your mods, it may be worth your time to continue researching this issue and filing a support ticket with the Blade & Sorcery developer.