Showing results for 
Search instead for 
Did you mean: 

Can not connect Quest 2 to Oculus desktop app PC Link

Level 3



I just bought Oculus Quest 2, I bought Oculus Link Cable as well. I really wanted to play some of the cool VR games as this is my first headset. I downloaded the Oculus desktop app, then when I try to connect my headset I am encountering many issues. I use the Oculus Link cable to connect the headset to my PC, and then:


1.) In the headset, I see a pop up menu for "Do you want to allow this device to access data" or something, before I even have a chance to select something, the menu disappears. After multiple times unplugging and replugging, I am able to eventually click on either "Allow" or "Deny" and either way, after that the menu disappears. Its like the pop up box service automatically ends within a couple seconds. 


2.) While the Oculus desktop app does not pick up my headset. It just constantly spins and I am unable to connect.


3.) The Oculus headset gets picked up as an audio device on my computer, so I know that the connection is going through. I've read on some forums that there are problems with Oculus if your computer's USB C is like connected to the motherboard or something... idk wtf that means but I think its pretty ridiculous that even though I have a spec'd out gaming setup, bought all the Oculus brand hardware, and I can't even get this setup properly. 


Posting here is my last resort to see if I can get this thing working before returning all of it.




Level 12

did you check first if your computer met requirements?


Also do you have the oculus app installed on your pc?


Post your pc specs, to let me see if you meet the requirements?

I do have the Oculus app downloaded and installed on my PC.


My PC specs are here:

msi GS63VR Stealth Pro (also says VR Ready)

Intel 7th gen core i7-7700HQ

GPU: Nvidia's GEFORCE GTX 1060

Video memory: 6GB GDDR5

System memory: 16GB DDR4-2400MHz

Storage: 256GB SSD+1TB HDD

Level 12

couple things to try:

go into device manager disable igpu

go into the nvidia controll panel make sure you select the gtx 1060 for the oculus app, laptops they tend to default to the on on cpu.


also the first question it asks you if you want allow or deny, you must deny.  Then on the enable link click enable.

Make sure your drivers and windows is up to date.

Hi, can you expand on this please? I don't know how this works in the Nvidia control panel.




also in the device manager


I tried all the things you mentioned here, I disabled the intel graphics card, made my global settings to be the nvidia processor, then the same problem happened. I went to go connect my headset to the oculus app, and then when i put the headset on, I saw the dialog box pop up asking me to 'allow or deny' but it stays for only 1 seconds before disappearing. I don't even have a chance to select something. Idk what else to do

it could be an unstable usb connection.  try a different port or swap ends, i know it sound weird.


but you deny the first prompt, then you enable link.

Edit— sorry, your card is on the list, I miss read your posted stat