cancel
Showing results for 
Search instead for 
Did you mean: 

Can't get Oculus link to work on Quest 2. Tried everything.

bzoei
Level 2

I am using the Quest 2 with a compatible USB-C 3.1 cable. I know it's a good cable, because Oculus Link used to work before. Now, either the oculus Windows app crashes and doesn't restart, or it says 'no service'.

I've tried:

- Restarting Quest 2, updated to newest firmware, turned off experimental features

- Restarted PC, reinstalled Oculus App twice. Tried reinstalling Oculus drivers, but nothing seems to happen.

- Used all USB 3.0 and 3.1 ports on my PC (specs: AMD 3600, Radeon 6800)

- Downgraded AMD drivers (from 21.6.1 to 21.4.1)

 

Any help would be appreciated.

 

Edit: after reinstalling everything for a third time, I can get the oculus app to work. I can also see the Oculus link (Rift) option on my headset. However, when I click it, the screen goes black for a second and then nothing happens. I can connect however with Oculus air. Why doesn't it work via cable though?

0 REPLIES 0