cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot load SteamVR home or most VR titles with Oculus Link but works fine with ALVR (Quest 2)

oO_Konan_Oo
Level 3

Hi, hope someone can help as I've scoured these forums and cannot find others with quite the same problem.  I have Quest 2 and a decent gaming PC and a Link cable and the Oculus software installed. I'm having trouble getting Steam VR and the majority of titles working when using the Link cable.  SteamVR and all titles work fine when using ALVR instead (but the quality isn't so good, so I really want to be able to use my Link cable).

I'm not even quite sure I'm "doing it right" and would be very grateful if someone could explain what you're supposed to do to get SteamVR running with Link (e.g. what order of apps do you open?).

I do the following:-

  • Open Oculus software on PC
  • Connect Link cable to Quest 2 headset
  • Enable Link when prompted on the headset
  • Run SteamVR from the Library menu on the head-set.

The result is that Steam VR loads on the PC and starts running but reports that it cannot detect the headset or controllers.  On the headset, the splash screen for SteamVR loading appears briefly and them I'm taken back to the Rift home screen.

Some games which I purchased through Steam, will launch on the Link cable just fine (Elite Dangerous, Star Wars Squadrons) but these games seem to have their own native VR support rather than relying on SteamVR to work.  I cannot get SteamVR home to load at all or most other titles such as Half-life Alyx or Phasmophobia.  These titles fire up SteamVR first and the game loads and starts running, but I cannot see anything on the headset and SteamVR reports it cannot find my headset or controllers.

If I don't use the Link cable and fire up ALVR on both PC and headset, then SteamVR home auto loads on both PC and headset and I can select all SteamVR titles from the SteamVR home screen in the headset.  They all load and run fine (it's just that my WiFi isn't quite good enough to give the frame rate and quality I would like).

I've uninstalled and re-installed Oculus and SteamVR neither of which helped. Any ideas would be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

oO_Konan_Oo
Level 3

RESOLVED - I hadn't realised that if you want to use both ALVR and Oculus Link on the same PC you need to manually switch between the two in SteamVR settings.  I had expected it to auto-detect based on whether I had Oculus software and Link running or ALVR Server.  The fix to get SteamVR working with Oculus Link was:

 

SteamVR > Settings > Startup / Shutdown > Manage Add-ons > ALVR_server = Off

 

Thank you to everyone who had tried to help me with this issue.  It was driving me nuts.  Best wishes, Tony

View solution in original post

14 REPLIES 14

nalex66
Volunteer Moderator
Volunteer Moderator

In the Oculus desktop software, did you enable "Allow Unknown Sources" in the Settings menu?

 

You could also try launching SteamVR from your desktop, after enabling Link. If I click the VR button on the Steam app and then put the headset back on, I launch into SteamVR Home reliably, and then I can launch Steam games from the menu there.

i7 5820K @ 4.25GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
SSDs: Intel 660p M.2 2TB, 3x Samsung Evo 1TB | Startech PCIe 4x USB 3.0 | Startech PCIe 2x USB C 3.1 gen2

Hi - Thanks for the reply.  Unknown sources are enabled.  If I launch SteamVR from the PC as you suggest I just get the same problem.  It loads, but doesn't detect the headset or controllers.  If you click on the headset in the Steam VR window it says "Headset is standing by. Move your headset to wake it up".  This is the same as if I launch SteamVR from the headset Apps menu.

Update - uninstalled and re-installed SteamVR.  Uninstalled and re-installed Oculus software.  Still same issue.  SteamVR home won't launch when Oculus software and link cable are used.  Launches ok fine if I'm using ALVR for wireless connection instead......  Still hoping for any ideas?? 🙂

what is you version 26 or 27 in oculus quest?  the new v27 has problem in cable link

satshanti
Level 4

I'm not sure if this will make a difference, but I use the Oculus Tray Tool. You can import your Steam library into it and afterwards all Steam games can be launched from the in-headset Oculus menu. Worth a try...

wilza7
Level 5

was thinking is it the registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1] and the "ActiveRuntime" value.  i suspect the Oculus Tray Tool is updating that as needed?

 

it can be configured with several different json files, depending what setup you're using.  so depending which you need it to be, stuff might or might not work.  most seem to need it flipping between the oculus json and steamvr json files.

I'm on Oculus app version 26.1.0.41.502 which is the latest version downloaded from the Oculus site when I re-installed my software

Satshanti, thanks for the suggestion.  I've installed Oculus Tray Tool, but I can't find the "in-headset Oculus menu" that you were talking about.  Do I need to side-load an app onto my Quest 2 as well as installing OTT onto my PC?  Where in the headset do I look for this launch menu, and is that in the Quest 2 stand-alone home, or the Quest Link home screen?  Thanks 🙂 Tony

Thanks for the suggestion.  This sounds like it might be on the right lines, but I've still not been able to resolve my issue.  HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1 was set to "C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json".  I've tried setting it instead to "C:\Program Files (x86)\Steam\steamapps\common\SteamVR\steamxr_win64.json" (I did this by selecting the "Set SteamVR as OpenXR Runtime" button in SteamVR > Settings > Developer.  I restarted Oculus and Steam but it didn't seem to make any different.  SteamVR still won't launch in the headset and the SteamVR window on the PC reports it cannot detect my headset or controllers  😕  Do you have any further suggestions please?