cancel
Showing results for 
Search instead for 
Did you mean: 

Extreme Bit Rate Drops [Air Link on Oculus Quest 2]

Alumian
Level 3

Hi everyone,

 

Is anyone else suffering periodic extreme drops in bit rate when using Air Link? I've recently moved home and my wireless network has changed slightly, but I'm comfortable that it's not an issue with my WiFi.

Before I moved, I could set the dynamic bit rate up to 200 mbps without ever experiencing even a single issue. Now, I need to have it set to pretty much 10 otherwise games are just unplayable. When I say unplayable, I'm talking like, when I move my head I see anything out of my previous FOV hasn't loaded, everything is heavily pixelated, my FPS plummets to around 1 and it can take 10, 20 sometimes even 30 seconds before the Oculus catches up and returns to normal (i.e. non-pixelated, standard FPS gameplay).
For clarity, my wireless network is configured as a router with 3 WiFi extenders connected throughout the house. One WiFi extender is in my office which is where I use my Oculus and the next closest one is down stairs, at least 10 meters away from it and through a wall. At my previous residence, I just had my router and I experienced no issues what so ever.

The reason why I am comfortable that it's not my wireless network is because of the following troubleshooting that I completed:

  • Tested Oculus on 2.4 GHz, 5 GHz and when the network is configured for Smart Connect
  • I thought the Oculus may be bouncing between WiFi extenders so I isolated the extender in my office and made it it's own SSID and forgot all other networks on my Oculus - issue persists
  • Already completed a factory reset and replaced the WiFi extenders incase they were faulty - issue persists
  • Disabled WiFi on all nodes except for my router (which I originally had no issues with) and I am now experiencing issues as described
  • I'm not experiencing any issues on any other wired or wireless device

 

Is anyone experiencing a similar issue or can anyone guide me on how I could further troubleshoot this?

Thanks

6 REPLIES 6

Alumian
Level 3

Welp, I just did a factory reset and when enabling Air Link I saw there is a disclaimer saying that mesh networks are known to cause performance issues so I guess that's on me. I suppose my next question would be could anyone think of a workaround apart from changing my network topography / using the Oculus Link Cable?

TomCgcmfc
Level 15

@Alumian  Actually after today’s Q2 update from v33….65 to v33…69 I’ve also experienced bitrate instability with Air Link. I have the recommended router/WiFi setup and a rtx3090 gpu.  I have not had any issues before today using 200mbps fixed bitrate.  Today I noticed lots of latency like blurry hands in the Rift home.  Lowering the bitrate down and/or using dynamic did not seem to help.  It seemed worse when I started up X Plane but seemed to settle down once I was airborne.  Still not right though.

 

I’ve tried a few things like removing my guardian history, resetting experimentals, and turning hand tracking on/off/on.  When I returned to the rift home things were much better but I still have some latency, especially with xp11 and MOH.

 

Not sure what to try next?  Maybe the new v34ptc?

 

UPDATE (3 hours later)

After a few restarts and changing the local frequency on my Q2 home from 50Hz to Auto Air Link seems pretty well back to normal.  Tracking still does not feel as good as it was before today's v33...69 update and I do see a very little more stuttering but it's still better than with Virtual Desktop (which I tried also back to back with Air Link).  I also got a win10 update today and this can often cause a few instability issues.  So, who knows?

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there Alumian! We know stuttering issues with your Air Link can take an incredible, immersive VR play session and turn it into an all-too-real, frustrating experience--but no worries, we have some tips and tricks for best practices when using this feature!

 

There's a ton of useful information regarding Air Link operation in general as well as minimum PC requirements here, but we'll hit the highlights and some of our known issues:

  1. Air Link’s performance might be impacted if the Wi-Fi channel switches from 5-GHz to 2.4-GHz during a session. Try to create separate networks for the 2.4-GHz and 5-GHz bands, or disable the 2.4-GHz band altogether.
  2. Check that you do not have a VPN running while attempting to connect and ensure that both your PC and headset are on the same local network.
  3. Make sure your firewall is not blocking the TCP port 5669
  4. Ensure that your graphics card drivers, Windows, and Oculus software are all up-to-date, and that you're running at least v28 of Oculus software. 
  5. Try uninstalling and reinstalling the Oculus home software. 

Be advised that Air Link is still considered an experimental feature, so bugs and mishaps are bound to happen, but we're trying to improve this experience for our users update by update. If you've tried all of the above and are still experiencing issues, feel free to send us a private message so we can look into things a little more: 

 

Please click here (https://ocul.us/OculusCommunitySupport) or on our name to get to our profile page, then click "Send a Message" to privately contact us.

 

Please remember, you must be signed into the community first to send us a private message.

Alumian
Level 3

Thanks for the replies, @OculusSupport in response to the suggestions you've supplied:

  1. I've tried splitting the network by wireless band and I've ensured that the node in my office is the only one broadcasting on 5 GHz, I've also made the Oculus forget the 2.4 GHz SSID to ensure no network switching
  2. No VPN is present
  3. Just double checked and the port is not blocked
  4. All drivers are up to date but I did notice that the Oculus did have a pending system update. I ran the update but it looks like the issue persists 😞
  5. As a last resort I did try a factory reset but it didn't help.

I'll send you a private message as suggested and I hope we can arrive at a solution for this.

Alumian
Level 3

No update to provide at the moment. I've sent 2 private messages through to @OculusSupport in the last 7 days but haven't received a response. Still waiting.

Alumian
Level 3

Still no reply. I guess we'll just have to wait and see if they fix the issues with air link on mesh networks *shrug*