cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware v25 broke Link Audio. My 108.35$ AUD Official Oculus Link cable is now garbage.

Wiggum007
Level 3

On version firmware 23 which what the quest I think shipped with had no problems with Link playing PCVR games.  I owned it for about a week or 2 and loved it. Now after version 25 the audio stutters and pops in POCVR with Link making the $108.35 AUD Official Oculus Link cable near worthless. You could try firmware v25 on PCVR link for 20 seconds and realize that the audio is completely broken. 

 

What is more concerning is they've been so loud about proclaiming the great new couch addition in V26 and teasing a Quest 2 pro, but I've yet to see any acknowledgement of them being aware let alone fixing the now broken Link experience and other issues brought on with v25.  This on top of the faulty Elite Strap and the skin irritation caused by the foam, it's made a purchase I love now hate. Also no option to remember to always allow connect on my computer? 

 

This has turned into a disaster, on top of it I purchased a 2nd Quest for friends n family use prior to Firmware 25 releasing. There was no option 'Would you like us to  downgrade your device, make your experience a lot worse or would you like to continue to enjoy a non-broken functioning product prompt." this broken firmware was forced on us.  

 

I tried 2 different computers, I spent hours uninstalling software, disabling onboard soundcard, tried different cable, different soundcards, updating drivers. Only to look on Reddit and realize other were having the same problem with Version firmwar 25 causing the exact same audio issues with Link v25. 

 

Can we please get some help/acknowledgement that Oculus is aware of the issue and are working to resolve this?

7 REPLIES 7

Kocinski73
Level 4

Hope that Oculus see & fix this problem since V23.

Oculus let the user decide about firmwares & updates.

Instead for a fix is the chance to get (after the couch) a bathtube is much bigger.

rocknrolz
Level 4

I have the same issue. It is very easy to tell just by listening to the choppy, stuttering audio. You don't even have to be in a game, it is very apparent even in the link home environment. 

 

Quest 1 is unplayable via link all of the sudden. Quest 2 is playable, but the issue is still there. I've been using link for a year and have loved it so much. I've had no hardware changes.

aguy10
Level 7

As lousy as Oculus support is I think it's still important you guys submit tickets if you haven't since they likely have a priority fix system based on the amount of complaints.

emveezee
Level 2

Same issue here, started at V25... the official Oculus Link cable now only shows up as being USB2.0 speed.. ( orange exclamation mark ) where it worked fine at USB3.0 speed before V25 dropped. Funny thing is.. a noname chinese usb cable works fine at USB3.0 still. I allready submitted a ticket 2 days ago but it has not gotten a reply yet.. needless to say this is not what you expect for a EUR 99,- cable..

 

Since Oculus Support was just stringing me along making me jump trough hoops, and even asking me If my Rift sensors were connected properly - I returned the cable to the store I bought it from.. And bought an Index..

Very disappointed with this whole thing..

So I have a submitted ticket regarding this and their reply included a number of trouble shooting steps.

 

In my case, the Factory Reset is the one that worked .

 

Hope that may help solve the issue for you as well 😉!


These were the full steps in the mail :

  • Reboot the headset. Click here for the instructions.
  • Ensure the volume is not set too high.
  • Test with multiple games/apps
  • Try with headphones.
  • Factory reset:
  1. Turn off your headset.
  2. Hold the power and volume (-) button on your headset down simultaneously until the boot screen loads on your headset.
  3. Use the volume buttons on your headset to highlight Factory Reset and press the power button.
  4. Use the volume buttons on your headset to highlight Yes and press the power button.

Denno2407
Level 2

Hey guys, after struggling with this problem for a couple of months and a couple of unsuccessful factory resets I managed to finally solve my issue.

I don't know if this will work for you but it is at least worth a try.

I've found that the stuttering through link is a software/bitrate problem probably related to the oculus software incorrectly claiming the wrong connection speed through link.

The steps I did to solve this are the following (not sure if everything is necessary, but just listing all the steps to be sure, thinking of it you can probably skip step 1-4 since all you're doing is refreshing the drivers, but I didn't want to take any chances and did that anyway)

1. Uninstall oculus software

2. Reinstall oculus software

3. In device manager manually uninstall Oculus Virtual Device

4. Navigate to (YOURDISK):\Program Files\Oculus\Support\oculus-driversInstalldisk:\Program Files\Oculus\Support\oculus-diagnostics and run Oculus-Driver.exe This will manually reinstall the deleted audio drivers.

5. Plug the oculus headset into your pc (preferably with usb3 cable)

6. Within the oculus software, go to device, click on your headset and run usb test (results should be above 250-300 mbps for proper use)

7. Navigate to (YOURDISK):\Program Files\Oculus\Support\oculus-diagnostics and run OculusDebugTool.exe

8. Set the encoding bitrate somewhere between 250 and your detected connection speed of step 6 (generally recommended to not go above 350 mbps)

9. In the debugtool, navigate to the tools tab and choose ''Restart Oculus Service''

10. On your quest enable link mode and see if your issue is solved

 

If this works, you can try running oculus link without the debugtool setting from then on (works for me) if that does not work then just start the debug tool and manually change the bitrate setting before every session.

Somewhere along these steps the oculus software gets forced to recalculate and reallocate connection speed and encoding bitrate which for me solved the problem.

 

Hope this helps some of you!