cancel
Showing results for 
Search instead for 
Did you mean: 

Fixing Oculus Link after update 13 + Audio issues fix.

BaileyAncom
Level 2
This method should be suitable if you do not live in English-speaking countries or the system language on your PC is not English. I live in Russia and after these actions my Oculus Link works like a charm. I also got a sound in my headset working.

The headset must not be connected to a PC until step 8!
The headset must be updated to version 13!

1. Enable PTC (Public test channel).
2. Wait for the app to update.
3. After the update, you should see a message to update the drivers. Update them.
4. After installing the update, make sure that the drivers are installed. ( In the device Manager on your computer, under "Audio devices" (or something similar), find "Oculus Virtual Audio Device" open properties and make sure it is version 14.24.25.681 (Maybe higher). Then close the device manager)
5. Close device Manager
6. Open the sound settings (type the word sound in the search), then open the "playback" (or something similar) tab. Search for "Oculus Virtual Audio Device" change the name to "Headphones"
7. Open the "record" (or something similar) tab. Search for "Oculus Virtual Audio Device" change the name to "Headset Microphone"
8. Launch Oculus Link.




Oculus.com store, please add shipment to Russia 🙂
7 REPLIES 7

ANTIpLAsH
Level 2
Thanks! Everything worked out! 

TheTonaZ
Level 5
now audio mirroring to pc speakers doesnt work no more

Anonymous
Not applicable
Yes it absolutely works with pc 14 and oculus quest 13. I am so amazed someone tried it and found it worked. Both input and output: "headphones" and "microphone" voila!!

ManaHime
Level 2
Is this supposed to make the mic work with the link? Isn't the mic disabled since v12 or something?

vargablood
Level 5
this only makes link and sound work - not the microphone. its disabled by oculus like you said.

leeonl
Level 3
yes,I get it .Now it works my way to the PC side or the headphone.

Nalfeyn
Level 2
For me audio mirroring does not work anymore after the fix. Any help?