Showing results for 
Search instead for 
Did you mean: 

HELP! Oculus Link Refuses to Work

Level 2

I will try to keep this short!

Specs: i7-8700k, Nvidia 1070, 32 GB 3000mhz.

Router: Asus RT-AX58U AX3000, Ethernet Cat6 to router and to PC.


I have tried two 3rd party cables to use for Oculus Link (Both passed the cable test. Green across the board) and any time I use them, it crashes and returns to Oculus home. The Rift Software will load most of the time without a crash. The game will typically load (main test game is Beat Saber on SteamVR. Also tried VR Chat) but the audio will be extremely choppy and buggy, and I will only get around 8-15 fps, then it crashes after around 10 seconds. I cannot figure why this is happening and it is extremely frustrating. I have tried everything from plugging the cables into different ports, switching cables, launching SteamVR and the games in different orders, and even uninstalling EVERYTHING (oculus software on PC, SteamVR, Virtual Desktop.... everything) and doing a hard reset on the headset. Still no luck. I have also tried virtual desktop (Using a 5ghz connection on a wifi6 router in the same room as pc and headset) which works great for everything except Beat Saber, I still get drops in frames (around 5 to 12) that make it impossible to play anything on expert difficulty. It isn't network latency causing the issue here, I have done close watching to the performance. I know my system can run everything smoothly, but it just isn't happening. I would love to play High FPS games using Oculus Link without spending the $80 for the cable... but I have exhausted all my sources that I am aware of. Any help with this would be awesome!!!