cancel
Showing results for 
Search instead for 
Did you mean: 

Help - Q2 starts up in passthrough mode and can't get to home screen or menu

Vortilon
Level 2

Hello all,

Turned on the headset today and get passthough mode only. I cannot get to home screen using menu button on right controller. Can't get anywhere except passthrough mode really and tapping side of HMD does nothing. Have turned HMD off and on several times, opted out of BETA in the PC app. When i did that it went through a setup again and installed new drivers - same results.

 

Any help would be greatly appreciated and if more info is needed, please ask and I'll post it.

 

Thank you!

10 REPLIES 10

u_b0n
Level 2

This exact same thing is happening to me too, no idea how to fix it.

I fixed it by reverting back to v24 of the Oculus app. That's not an ideal solution but at least I can use the HMD. If you want to try, follow the instructions here:

 

NOTE: I did not create this workaround so you use at your own risk. Hope this helps and good luck. I found this at another site - it is not my work.

 

But there is a
way to revert it to v24 and stop the updates. Here's instruction and google drive link to v24
Download this zip folder here:
https://drive.google.com/file/d/1ffQs4cCI-zMuYq3UMeH1a-WqypEEuIuS/view?
fbclid=IwAR3DGsWsea4AGqKXcU3MUze3DniY5KC9PthZgNMwekTuGCriLmYUUn-b5Qs

in task manager, close OVR Service Launcher then in oculus folder rename "support" folder for whatever
"2support" for example. And put the "support" folder from the zip from google drive to oculus
folder.
Check if you have Staging or TMP folder in oculus folder, if you have any of those two, erase them
(they should be empty either way those are folder that keep the new updates coming in...). Now
from the zip folder take the files Staging and tmp and put them in oculus folder. And done it may try
to download newest update but it will not be able to, it will be queued and we want that : ).
And it's done. : ) It will still show that it's at v23 still but it's not. To revert it is simple, shut down the same Oculus service in task manager, erase those
staging and tmp files, and it will update to v25.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hi there! We'd like to check this out further with you to see what's going on here. Can you please click here to submit a ticket? Thanks!

Didn't work. I use quest 2 as a standalone HMD.
I start it up, it shows my VR space for a second, then shows passthough.
No amount of side tapping helps resolve this.

Lunar_Tick
Level 4

@OculusSupport  You geniuses released a bad update AGAIN. Surprise! Every time you release a big update, you break random stuff. I tried casting tonight. Nothing. That crashes. Now I'm stuck with the same condition as OP. Stop ruining your product with lack of testing.

Vortilon
Level 2

Update. Even after reverting to V24 I've still had the start up in pass-through issue but not every time. My workaround now is comprised of two actions. When booting up the HMD I make sure that none of my fingers or hands are anywhere near the cameras / sensors on the headset. Second, I now turn on the headset with it resting on my desk camera side down. This seems to work most of the time. Sadly I'll have to agree with the post above this one that Oculus is not doing a good job with their update process. They seem to address a few issues but instead cause that many or more in the process. I primarily use VR for MSFS2020 flight simulator and the official MFS VR forums are filled with issues related to the Oculus software. Many users have opted to use Virtual Desktop to connect the sim to the headset thus eliminating the buggy Oculus app software. I may do the same. 

Sp0uny
Level 4

Hi,

For 1 week or 2, I have exactly the same problem, when I start my Quest 2, almost every time it starts up in passthrough mode and can't get to home screen or menu.
Completely stuck like that, no other option but to turn it off or restart it, but it always reboots like that.

I ended up contacting Oculus support, they made me reset the headset to factory settings, I was not really happy because I lost my saves and my progress in my games, but at least it allowed restart the Quest 2 without being in passthrough mode.
The problem was solved until I used it again in link mode on the PC. I deduced that once again it is a problem related to the use of Oculus link.
Currently I still have this problem, almost every time the Quest 2 is started, but I have figured out how to get the home menu and use the Quest 2.
I have to start the Quest 2 (it will lock in passthrough mode). Then I connect the Oculus link cable to the PC and launch Oculus Link from the PC.
I notice that the Quest 2 is recognized and connected in Oculus link.
Then, after a long press on the power button of the Quest 2, I can choose "to turn off" or "restart" the Quest 2.
Usually it's OK the first time it restart, but sometimes I have to redo these steps 2 or 3 times, but at th end I can unlock the situation without resetting the Quest 2 to factory settings.

Sp0uny
Level 4

By the way, if this can help Oculus Support figure out how this issue might occur, I partially remember what happened right before I first had this issue.

That said, I'm not sure if this issue is really related to it or not, but it first happened right after what I'll describe below.

While I was playing, Oculus link detected that an update was available, but I didn't notice it when I was playing. After I finished playing, I disabled Oculus link from the Q2, then turned it off.

On My PC, Oculus link was still running, and I saw in the notifications the availability of an update, and I launched it (thinking it was just an Oculus link update).

After that I do not remember if it asked me to connect my Q2 for the update, or if I simply noticed that the Q2 was turned off and I said to myself "if there is a need for Q2 update, it will be done the next time I'll connect it with Oculus link.

But I didn't use it for a few days, and when I wanted to use it, it was in stand-alone mode for beat saber.

So I started it not connected to the computer, and it started stuck in passthrough mode.

Also, I specify that I systematically deactivate the guardian mode when I play sitting at my PC, because even in static mode the circle is not large enough, it sometimes detects an exit from the playing area, which is very painful in the game.

So, the update was done while I had the Q2 configured on guardian "deactivated" in the development options.

I thought that my problem could be related to the fact that I use the Q2 with these settings.

Lunar_Tick
Level 4

Mine got stuck with no use of Link whatsoever. I have a Link cable and use Virtual Desktop occasionally, but this was an entirely separate occurrence.

 

I was trying to cast to Oculus.com/cast and it wouldn't work. I'd cast in the headset and the red dot would appear then disappear. Eventually it was saying Oculus was crashing or something. Then I decided to turn off Guardian under developer mode after restarting it several times to cast since it seemed like Guardian was having issues. I thought maybe that was interfering with stuff. Then I restarted it one more time and it got stuck on passthrough.

 

I had to factory reset, which is pretty annoying to say the least. And you can't skip all the setup BS.