Showing results for 
Search instead for 
Did you mean: 

How do I connect the Quest 2 to my PC?

Level 3

I got the Quest 2 a few days ago and I've downloaded the Oculus app for the PC. But when I try to add the headset the app wants me to connect the USB-C cable (the only cable I got with the Quest 2 is the charge cable) to my PC, but I don't have an USB-C port on my computer. So how am I supposed to get access to settings and features like setting the headset to the 90hz refresh rate or change other settings? Why don't they include cables for users who don't have a USB-C port, because everybody doesn't have that. It seems so backwards. I tried using an USB-C to USB-A adapter to connect the headset to the PC, but it didn't work. I have googled my problem, but I can't find any solution. Surely I can't be the only one who has had this problem?


Level 4

The headset does not come with a USC-C cable long enough to use with Oculus Link. You will need to buy one. Oculus sells one for around $70, but you can find them cheaper online or at your local electronics store. I recommend getting one that is at least 10ft long (15 preferably). If the listing you look at is measured in meters, then get 5meters long.

Until Oculus fixes the issue with firmware version v26, I recommend getting a Type C to Type A cable. Type C to Type C cables can no longer charge the headset when connected to a PC on the current firmware, but C to A still works normally.

Level 11

the charge cable is not a usb 3.0 cable, and is not designed to be a "link" cable.  You need a link cable or compliant usb 3.1 type a to type c.  Type 2.0 can do link but you need to careful of render scale and hz, as latency and data transmission is not stable, 2.0 cables are only rated up to 480 mb/s.


Open the app on the pc.

Turn on the headset get to the home screen

plug the cable into the usb port of the headset and computer.

Look into the headset and use the touch controllers to select the following.

It will ask you to allow or deny select deny on the first prompt.

It will ask you if you want to enable link click "enable link"


once connected, you can look at your desktop and adjust render resolution and hz, in the devices menu.

We have a quest oculus 2 and purchased a USB cable to connect the oculus to our PC. We downloaded the Oculus app and can get as far as the prompt to allow access to data. We have selected allow and deny but cant get the oculus link to pop up. It pops up that the PC is disconnected. It shows in the PC's setting that the oculus is connected. Any idea on what to do? Thanks!

I don't know your computer specs and setup, so it's hard for me to give you an answer.

Disconnect/reconnect the USB cable until it works. Sometimes it just does that.

Plug it into a USB port directly built into your motherboard and it happens less often (though it may not completely stop). Also make sure both your PC oculus app and the headset are using the latest firmware version (despite the latest version having it's own issues).

I managed to connect the Quest 2 to my PC with the adapter using the rear USB ports on my PC, but the app tells me it's USB 2.0 and I can't change the refresh rate. I know the rear USB ports are 3.1 and the adapter is USB 3.0, so I don't know what the hell is going on.

In my experience, anything other than a usb-c to usb-c cable will be detected as usb 2.0, including a usb-c to usb-a 3.1 cable like you are using.

You just have to keep unplugging and reconnecting the cable from your headset and PC and trying to connect the Oculus Link until it starts working. This obviously isn't ideal and Oculus needs to fix it, but for now it's all you can do.

Depends on what the cable rating is and the specific port that it's plugged into.
Case in point, I went to the trouble of getting a cable that's specifically rated for USB 3.1 Gen 1 (also known as USB 3.2 Gen 1) - so 5gbps rated. The cable has usb-a at one end and usb-c at the other - but the important part here is that the usb-a port on my pc is USB 3.2 Gen 1 (also known as USB 3.1 Gen 1).
Funnily enough the only time I had the issues you guys are describing was when I borrowed a friends usb 3 cable that was using multiple adapters. Would NOT work with all of his adapters on it, but with some of them removed, usb-a to usb-c worked...even if it was poorly. Once my purchased cable arrived, no need for adapters and smoothly played the SteamVR version of Arizona Sunshine with no issues.


So as long as the cable rating is correct, and the port has the correct USB 3.2/3.1 revision, then your physical part of connecting it up should just work. On the safe side though, make sure you update pc firmware and software drivers for motherboard. Updating the Quest 2 might help as well.

For the other part M36ABYT3 , actual streaming content from PC. What are you trying to play from the PC to your headset?

The adapter I was using is an USB 3.0, but it's recognizing as USB 2.0. I'm gonna get a cable like the you describe and try that.


I'm using Virtual Desktop over a 5GHz wi-fi connection to stream my SteamVR games, I don't have any issues with that, it's just connecting my Quest 2 to the Oculus app on PC via a cable.