Showing results for 
Search instead for 
Did you mean: 

How do I run Alcove on Quest2?

Level 2
Downloaded Alcove on PC says purchased but not showing in Oculus apps. How do I run it? 

Level 8
I'm a little confused by your statement. Alcove is not a PC app, it is a Quest app. You can purchase it on the Oculus website, but you can't purchase it or install it in the Oculus client.

In your Quest headset you should go to the Store and find Alcove. It will say purchased and you can initiate the download and install from there.

i7 8700, 16GB, RTX 2080 TI, Rift CV1 | i5 4690K, 16GB, GTX 1660 TI, Rift CV1 | Quest | Quest 2

Level 2
Thanks for the response Nunyabinez... The problem is when I go to the store Alcove isnt there. I type it into the search and get the response  no results showing "alcove"   . It suggests I try VR chat instead. Im new to using Oculus Quest 2 and maybe Alcove isnt available on that set? I can find it in my browser and it says it downloads there but then there is only a greyed out button that says Purchased. I cant do anything with it.