cancel
Showing results for 
Search instead for 
Did you mean: 

How to stop all disconnects from WiFi on the oculus quest

dingofoxvrfox
Level 4
Ok the problem is called dual channel WiFi this is a common protocol used by Comcast and even dsl providers.

Basically this issue is telling the quest to connect at 2.4 ghz but also your 5ghz channel is the same name as your 2.4 ghz channel.

which confuses the quest causing a loop connection failure which disconnects your WiFi.

how to fix 

name your 5ghz channel on your router one name and name your 2.4 ghz channel another set the 2.4 ghz Channel to channel 11

set your 5ghz to 108 or 120 if your router supports it 

then click save or continue 

(side note Comcast’s wireless settings are controlled by there app and will complain taking them off of automatic may cause issues) this is a bull message ignore it 

reconnect the quest to the 5ghz channel 
9 REPLIES 9

Icepick869
Level 4
If your router allows you to create a virtual access point you can do that for just the Quest. You can set the VAP to act as a standalone VLAN or still be on the same Lan as all of your other devices. This can resolve other issues as well, but they have their own threads. 

bobkbrown
Level 4
Thanks for sharing!
I use Unifi AC Dual Band AP's at home and it combines the 2.4 and 5 Ghz... absolutely no issues.
This must be an isolated Comcast hardware/wifi issue. Be sure your modem/router FW is up to date. 

dingofoxvrfox
Level 4
It’s not the combination that’s the issue it’s the quest tries to stay connected to 2.4 ghz and loses the connection then try’s 5 ghz channel and fails to log in causing the WiFi disconnect 

Craash
Level 2
I have this problem on Netgear Orbi, and have had the problem for months before it got bad enough for me to go online to look for a resolution.   I don't think I have the ability to turn off the 2.4G band, I've looked everywhere in the configuration, including advanced wireless settings.. it seems they try to simplify things a bit too much.
My orbi system has two satellites (repeaters), and the relevant config is currently:
    Hardware version: RBR20
    Firmware version: V2.3.5.26
    GUI Language Version: V1.0.0.360
    --Wireless settings--
    Region: Canada
    2.4G Channel: Auto (8)
    5G Mode: Up to 400 Mbps
    5G Channel: 36+40+44+48(P)
    5G Mode: Up to 866.7 Mbps
    2.4ghz b/g/n:
      Enable 20/40 Mhz Coexistence
      Enable WMM
     Preamble mode auto, transmit power control 100%, 
   5ghz a/n/ac:
    Enable WMM
     Preamble mode: auto, transmit power control: 100%
    Backhaul topology: Enable Daisy-Chain Topology

   NOT checkmarked:
     [ ] Enable Implicit Beamforming
     [ ] Enable MU-MIMO
     [ ]  Enable Fast Roaming

I have the guest network turned off, my first attempt after looking for firmware updates is going to be to try turning it on since it uses a different SSID, in case that SSID is restricted to only one of the bands.

richardking01
Level 3

Thanks for sharing this with us. It's not only with you, many of us face the same. 


KarstenS80
Level 5



name your 5ghz channel on your router one name and name your 2.4 ghz channel another set the 2.4 ghz Channel to channel 11



Thats a workaround, but no solution.

We have over 20 devices, that have no issue with the dualband WLAN mesh at all. Windows, iOS, Android and some other types of operating systems. No issue.

Only the Oculus Quest have issues. And the error it shows when it happens is that the authentication has failed. 

Prosposal: The WLAN driver Oculus does use is trash.

gregor616
Level 5
The newest FIOS router uses SON and only has one name available so you cannot split the network names. Never had this issue until I got this new router (my quantum died). Now every time I put my headset on I have to reconnect tot the Wifi. 
Oculus Quest 
AMD Ryzen 7 2700, GeForce RTX 2060 Super, 32GB, Asus B450 Motherboard

richardking01
Level 3
Thanks for sharing this with us. It's not only with you, many of us face the same. Few time back, I encounter this problem on my Linksys, and I was looking solution for this. Luckily I got to know about the website linqssys.com, they helped me to get rid of it.

edwardkortiz
Level 2
Hello, guys if you are looking for any kind of issue resolver of WiFi. guys feel free to visit on Netgear Nighthawk Setup or Netgear Nighthawk Router login. our website- nighthawklogin.net