cancel
Showing results for 
Search instead for 
Did you mean: 

How to use 120Hz Link (wired and Air) (V29 Quest, V28 Oculus, downgrade links)

Espionage724
Level 4

* V28 Oculus PC Client
* Folder of other Oculus PC Client Versions

__________________

Info:

Seemingly, you need V28 Oculus PC client currently, as the 120Hz option doesn't show on V29. Currently, the Oculus PC client is at V29 on both stable and PTC, so the only way to have V28 if you upgraded is to manually downgrade.

It's assumed you need V29 on the Quest 2 as well, but this is untested from V28. You can sideload V29 freely, with the update archive here and the guide here.

__________________

Downgrade instructions:

1. Stop Oculus service (Debug Tool -> Service -> Stop Oculus Service; sc stop OVRService may work too)
2. Back-up and remove everything in the C:\Program Files\Oculus\Support folder except the oculus-dreamdeck-nux, oculus-touch-tutorial, and oculus-worlds folders
3. Copy archive contents into that folder of whatever version you're installing (V28 (28.0.0.222.469).zip in this case)
4. Do steps in README.txt in Prevent Oculus Client Updates.zip to prevent Oculus from automatically updating itself
5. Start Oculus Service (step 1 with Start instead; also sc start OVRService)
6. Win

2 REPLIES 2

TomCgcmfc
Level 15

So are you saying that if you currently run an Oculus app repair on your PC you end up with v29, not v28?  I ran a repair a couple of days ago and got what I thought was the current v28 stable.  I also ran a factory reset on my Q2 and ended up with v29.  Both of these have the 120Hz option (standalone and Link, including Air Link).  

 

I been playing around with 120Hz with Link and Air Link and so far I'd say you are not missing much.  Even my fairly high end PC (i9 9900k/RTX3090) struggles a bit and I personally do not see any advantages over 90Hz.

 

I think people need to remember that like Air Link, 120Hz is still very much Experimental so I don't think you need to rush in and muck around with your installations.  There currently is no 120Hz brass ring at the end of all that, maybe just a bricked system, lol!

 

Anyway, just my thoughts.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

TomCgcmfc
Level 15

@Espionage724  I just got final v29 Oculus Desktop app today.  I also have v29 on my Q2.  I found that all I needed to do to get the Q2 device quality settings was to get out of Air Link, shutdown the Oculus desktop app, go to the Q2 experimental settings, and enable 120Hz.  Then when I restarted the Oculus Desktop app, enabled Air Link and reconnected it, the 120Hz option re-appeared.  Easy peezy imho.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro