Showing results for 
Search instead for 
Did you mean: 

I have my Oculus Quest 2, but it won't link with the app.

Level 2
Hi! I bought my Oculus Quest 2 on the 13th, and it's my first VR headset. I've enjoyed it so far, but I'm not able to hook it up to my PC. I got to the setup area and selected my headset. I was at the part where the (PC) app was trying to pair with my Quest and it couldn't find it. I also tried going into my headsets settings and activating Oculus Link from there, but the oculus couldn't find the app. However, when I plugged in my oculus (I used the stock cable) my PC had a notification telling me it detected it, and my Oculus asked if my PC could access the files on the Oculus. So I'm confused about what I'm doing wrong. Sorry if this is confusing, my English needs some work. Other than that, I have had no problems with the headset. Other than short battery life. 

Edit: I got my USB 3.0 cable today. I tried it out yet, it still didn't work. The little plastic inside of my PC's USB ports are black, and I think that means it's a 2.0. I'm gonna head back to where I bought the headset tomorrow to see if I can find some help. I might buy the Oculus brand link cable tomorrow. We'll see what happens.

Level 2
Same problem here. I'm using the official link cable from Oculus and it can't find my Quest 2. My PC doesn't recognize it at all. When plugged in with the charging cable, I'm able to connect.

Level 13
if your see this in the quest Oculus asked if my PC could access the files on the Oculus, you have to deny it. then enable the link on the home menu.

Level 2

if your see this in the quest Oculus asked if my PC could access the files on the Oculus, you have to deny it. then enable the link on the home menu.

I'm gonna try this now, I'll get back to you! 
Edit: Just tried this, it said it didn't work. However, I think I'm using a USB 2.0. Will this still work? (A type to C type). And FYI: I've tried with the stock charging cable and denied the access files. Did not work

Level 5
I had the same problem had to totally delete the old app updating it don't work. installed the new app then everything worked.

Level 2
I have the same problem, @Kryptaro , have you found a solution?

Level 2
I got into a right state installing mine.
But it worked after I realised I needed to install an app on my mobile phone, connected with the Quest,  and then I enabled Oculus Link in the headset settings. After plugging in the USB cable (generic) I was on Steam VR and Redshift and happily creating a neck twinge in seconds.
I have seen other suggestions to disable USB power management in the Power Management settings in Windows 10.
Otherwise, update your motherboard drivers in case your USB3 is duff.

cant find the setting to enable oculus link 😞

Hello! We want to help you get Oculus Link up and running on your PC. Oculus Link requires a high quality USB 3 cable capable of supporting data and power, and it must be plugged into a USB 3 port on your PC. They'll usually have blue plastic in the port. In addition, the included Quest 2 charging cable will not work with Link. We strongly recommend purchasing the Oculus Link cable for use with Link. For more info about Link compatibility, you can click HERE. Hope this info helps! We're here to answer any other questions you may have!

Hello! I just wanted to check in and see if your issue has been resolved.