Showing results for 
Search instead for 
Did you mean: 

I need help.

Level 2
No matter what I do, my oculus link won't work. I've tried every fix I could find, even here on the forums, and I can't find a solution to my issue. The only thing I can possibly think it can be is that I don't have a USB-C port in my PC. But then again, I've tried adapters, cables that are USB-C to USB-3.0, and a PCIe card and none have solved the issue. Another thing that happens is when I try to plug my cable in a USB-3.0 port, it either says it's a USB-2.0 or it doesn't say it's plugged in at all (which happens 99% of the time). When it says my quest 2 is plugged in, I go in and follow all the steps that the official Oculus website says to do, and still, the screen will go black and send me back to the home screen. On very very rare occasions it will be on loading and stay there with no end. Can someone help? I've spent way more than I needed to on trying to fix this, and really want to experience what else VR has to offer.

Level 2
Also here's my PC specs:
Graphics card: Radeon RX 580
Processor: AMD FX(tm)-6300 Six-Core Processor (only has 3 cores)
Ram: 16GB