cancel
Showing results for 
Search instead for 
Did you mean: 

In a place that blocks Facebook? Stuck at 0% downloading or can't sync media? Here's how to fix it

iGerman
Level 2

If you're in Russia, China, Belarus, or any other country or place that blocks Facebook, do not factory reset your headset. When you reset your headset, it will ask to update, but it will never actually download the update, and you won't be able to complete the setup.

If you have reset, here's how I fixed being stuck at the update screen.

This is also a fix for not getting updates, and media syncing not working on a functional headset.

 

If you are stuck on 0% downloading, here's a couple things you can do:

  • Set up a VPN on your router. Mine supports OpenVPN so I used the highly popular in Russia AntiZapret. Refer to your router's settings and manuals to see if/how you can do that.

That's what I did.

 

Other ways:

  • Set up a VPN'ed hotspot from Android and connect to it from the Quest. You will need to have a rooted Android phone. Use VPNHotspot.

  • Set up a VPN'ed hotspot from a Windows PC. Guide from NordVPN on how to do that.

  • Set up a VPN'ed hotspot from a jailbroken iOS device with TetherMe.

For me, the Facebook block also prevents updating and media sharing, as well as the Store is spotty with images and videos. You could probably try sideloading a VPN app like OpenVPN, though I haven't tried it, and I don't know if the VPN functionality is even present on a Quest/2.

 

I've tried specifying a proxy, but the only UI element to do that isn't clickable (first stages of setup when you connect to a WiFi, there's a proxy option but it's just greyed out), through ADB shell commands it didn't work.

0 REPLIES 0