cancel
Showing results for 
Search instead for 
Did you mean: 

In-game frame rates fixed at 36fps?

martinlest
Level 3

Apart from the apps on the Oculus itself, I only use my Quest 2 to fly VR in X-Plane 11. There is some odd behaviour there that I don't understand. Can anyone help?

 

I can see that when flying XP11 my fps is being held at 36fps (not 35 or 37).. exactly half my headset refresh rate. Every minute or so, however, the frame rate starts climbing.. it gets as far as 60 or so, and is then 'pulled back' to 36. I have no VSync option set anywhere (in X-Plane, nVidia CP or wherever) and I check that ASW is turned off before I start each flight (at least while I am trying to understand this 'issue').

 

In fact 36fps gives me a nice smooth VR experience, so long as it remains steady, but I am mystified as to what is keeping it at exactly that rate. When it climbs for a few seconds, what could be pulling it back down again to half my Oculus refresh rate?

 

Thanks

3 REPLIES 3

martinlest
Level 3

With the headset at 90Hz, I get a stable 45fps in X-Plane. Great. Still wonder though by what mechanism 90Hz translates to 45fps, as I do not have any VSync set, and if I turn off ASW (I leave it at auto by default), the frame rate stays at 45fps. Don't get me wrong... I am delighted to get 45fps but mystified as to what is creating the half refresh rate fps.

TomCgcmfc
Level 15

@martinlest With my Q2 I'm mainly running Air Link at 80Hz refresh on everything right now because I do not seem sensitive to it and my performance is a bit better than 90Hz.  I have a rtx3090 so I can also max out the res slider full right.  Together with v33 lens sharpening I think the visuals are pretty stunning.  I also use OTT but only to turn ASW=off, SS=0, and gpu scaling=enabled.  I'm also using 200mbps dynamic bitrate from the Oculus home dashboard menu.  All my ODT settings are default or 0's except Link Sharpening = Enabled.

 

With X Plane 11.55 Vulcan I generally notice that my FPS stays pretty well around 40fps in busy areas and sometimes hits 50-60fps in open areas.  This does not seem to effect anything and all's nice and smooth.  I can fix this to 40fps by selecting ASW=45fps fixed (based on 90Hz, so 40fps at 80Hz).  However, this does not seem to make much difference and actually seems a little smoother to me with ASW=off.  You can try pressing ctrl+num1 to turn ASW=off and ctrl+num2 for 45fps fixed, no asw, and you can do this on the fly to see what works best for you.  I personally do not like xp11 with any asw because I get too many wavy artifacts.

 

Without asw I don't think there is any magic xp11 thing that likes to target 1/2 refresh rates.  This is something I target when I'm playing around with xp11 settings and this is what most other users do as well.

 

With xp11 (or any flight sims) I don't think you should concentrate/worry too much about FPS.  Your Goal is to get smooth, stable results with as good visuals that your PC specs can deliver imho. 

 

Edit; also make sure you are not using vsync with xp11 (bottom box of the xp11 graphics settings).

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro


With xp11 (or any flight sims) I don't think you should concentrate/worry too much about FPS.  Your Goal is to get smooth, stable results with as good visuals that your PC specs can deliver imho. 




Hi. Quite right. In the end, though I get 45fps easily, and stable, when flying over default scenery and with default airports, that is something I hardly ever do - I fly over 'Otho4XP' terrain (satellite imagery), which takes (or can take, as you probably know) a huge toll on frame rates. With the fps wavering between 36 and 45, the sim is no longer smooth and stutter-free.

 

So I have installed a (lua) script into X-Plane which, in the Quest 2 at least, limits the frame rate there to 24fps (it is supposed to be 30fps, but in X-Plane 11 VR + Vulkan, 24fps is for some reason what I get).

 

24fps seems low but is a frame rate that the sim only rarely fails to achieve, even with 'heavy' addons and |Orhto4XP terrain, and the result is a whole lot smoother (as you rightly say) than the flickering around 45.

 

Pretty sure I set VSync to 'off' in XP11 (I'll check). I also use the XP Debug Tool, but I think that the lua script disables ASW anyway..

 

Thanks again 🙂