cancel
Showing results for 
Search instead for 
Did you mean: 

Intel NUC 11 Enthusiast not working with official Oculus Link cable

gsdm_usaf
Level 2

Just want to give people a heads up here.  The official Oculus Link cable will not work with the NUC 11 Enthusiast. For some reason, which Oculus support cannot explain, when using this particular cable the headset will continuously disconnect from the PC when you enable Oculus Link in the Quest 2 headset.  It will stay connected anywhere from 30 seconds to 2 minutes.  I guess the Thunderbolt 4 ports don't like this $80 cable. 

 

Also, it will sporadically display USB Not Recognized while other times it will display XRP Interface in the Device Manager. 

 

Either way, I have bought and tried every other $25 or less after market cable listed below and all of them worked with no issue.  But yet, the $80 "Official Oculus Link Cable" is the only cable that does not work.  Funny how that works huh?

 

- 6ft USB C to USB C 3.0 Gen 1

- 10ft USB C to USB A 3.2 Gen 2

- 20ft USB C to USB A 3.0 Gen 1 

 

I am running an i7 with a RTX 2060 32GB RAM.

 

Let me know if anyone is also seeing this with other systems. 

0 REPLIES 0