cancel
Showing results for 
Search instead for 
Did you mean: 

Is link with Quest 2 broken?

Gigglebooster
Level 3

Whenever I enable link on my quest 2 I can hear the sound from the game coming out of the headset, but inside I only see 3 dots like it's loading. It does this for about a minute and it will eventually kick me out link and send me back to the regular quest 2 home screen. I've done a factory reset on the headset and reinstalled the oculus software on my windows computer. Is anyone else having this issue? I haven't even been able to use my Quest 2 for the last couple of months because it's been broken with all of these updates after v26, is there a way to go back to those older updates?

8 REPLIES 8

agtmluis
Level 2

Do you happen to be using a Laptop with a integrated and dedicated graphics card?

Same issue for me, using a laptop.

kr0e3
Level 2

I'm having the same issue, I'm on a desktop and its giving me the 3 dots than back to the quest menu over both the cable and air link.

Nope, I'm on a desktop. I have an RTX 3090 for graphics card installed. However, I'm using a Ryzen processor that has integrated graphics as well maybe it's trying to switch to that or something. Idk the Quest 2 kind of sucks haven't been able to use link cable since update 26.

EAJEAW
Level 2

try updating the usb drivers it kinda works i mean for an hour then you get kick to the oculus home

 

Tried updating them, said they were already on the latest version.

you might have to find some ur self its really a 50/50 chance

 

sacolton
Level 2

Uninstalling SteamVR and re-installing fixed the same problem for me.