cancel
Showing results for 
Search instead for 
Did you mean: 

Is there an option on Quest 2 to "always allow" access to my PC?

taidoq2vr
Level 4

Greeting:

 

Just get the Quest 2 and am tired of putting the headset on to click "allow" every time I plug into my PC.  Is there a way to "always allow" access to my PC?

 

Your help is greatly appreciated.

7 REPLIES 7

Pixie40
Level 10

Only way I can think of is to leave it plugged into the computer.

Lo, a quest! I seek the threads of my future in the seeds of the past.

Thank you all for your feedback!


Shame that such simple functionality is not available which could minimize repetitive task frustration.

wuffzack
Level 3

Yes, click the "third" button. I don't remember the wording, but it was something like "don't ask again". I clicked it, wondering if this means "always deny" or "always allow", and it turned out to be "always allow". At least I think so. I can use Link and can access files on the Quest.

Thank you for your feedback.

 

 Unfortunately I don’t have 3rd button.  I see only cancel or allow.  

Pixie40
Level 10

I've seen a "don't ask again" checkbox a few times, it's not consistent. Personally, I'm not too bothered by it asking if I want to enable Link. Sometimes I want Link on right away, other times I was just plugging in the headset to charge it while watching Pluto TV or chatting with friends in Alt Space. What bugs me more is it asking if it's okay to allow my PC access to my Quest 2 Every Single Time I plug it in.

Lo, a quest! I seek the threads of my future in the seeds of the past.

<<. What bugs me more is it asking if it's okay to allow my PC access to my Quest 2 Every Single Time I plug it in.>>


This is exactly what I meant.  Why can Occulus give “never ask again” permission option?

SublimeStudios
Level 2

For everyone still struggling with this: here's my solution to get rid of this repeating message.

 

The problem is that you have to authorize your Oculus with ADB, and once that is done you can simply switch off the usb message and a new world order of rest and peace will settle upon your soul.

 

1) First you should install the Oculus ADB Drivers 2.0 and add the platform tools:

 

https://developer.oculus.com/downloads/package/oculus-adb-drivers/

 

https://www.youtube.com/watch?v=cD6zsHQdoXY

 

 

2) Unplug your Quest from your PC's USB. Wait 3.14159265359 seconds precisely (just kidding). Plug your Quest back in again.

 

3) Now enter 'adb devices' in your command line prompt. It should show your device and behind it 'unauthorized'.

 

4) Mount your Quest (put it on your head). Now you should see that other message that allows you to ALWAYS access your Quest through your PC's USB connection.

 

5) For the second message (which you have been seeing thousands of times until now and which drove you to near insanity) just click 'Don't show again'.

 

6) Now enter 'adb devices' again and if correct, your Quest is now 'authorized'.

 

7) Unplug your Quest and plug it in again. You should get no prompt in your Quest and 'adb devices' should still should your Quest as a registered and authorized device.

 

8)) If any of this fails, reboot your Quest and try again.

 

9) If it still doesn't work for you then this tutorial doesn't work for you, sorry.